There Server is Older Than My Client?

ok well it does this for me for every server i try to join then i asked my friend to update his server and now he updated his own to the current update and now he cant even play his own server anyone else got same problem or know how to fix just wonderin

Obvious pirate.

In the first place: Fill in your profile data on this website, so that we can see if you have a LEGIT (bought) copy of GMod.
Second: If the servers version is older than the client, you should update the server again.
If he just updated it, do it again, because there could have been an update in the meanwhile.

There was a Garry’s mod update today, all servers need to be updated.

Their server was probably up for longer than your GMod was, so they didn’t autoupdate.