'This game is currently unavailable' Error

This started just today, I tried starting up GMod several hours ago and it said 'This game is currently unavailable. I’ve restarted steam, restarted my computer. I’ve tried all the suggestions on the Steam page here, and none of them have worked.

Does anyone know what to do?

Wait until the game is currently available? Duh

I’ve been waiting since 5:30 and it’s now 11:00. It’s not a ‘wait it out’ issue I’m pretty sure.

Just wait ;0 trust meh

Waiting clearly hasn’t gotten me anywhere, it’s still giving me the ‘game is currently unavailable’ error and it’s been twelve hours since my last post. Does anyone know how to fix this?

I fixed it because one time when I was playing, the game crashed, and so it showed that it was closed, but the process was still running in the background. So I opened my task manager, and ended the process “hl2.exe”. Then it fixed for me.

The problem with that is it started when I opened up Steam, hl2.exe wasn’t running in the background.

Make sure GameOverlayUI.exe (or whatever it is now) isn’t running either.