"This game is currently unavailable."

Well, the image says it all:

http://img43.imageshack.us/img43/9841/errorqf.png

This is fairly recent, possibly after Garry’s most recent patching of Gmod.

This is what I have done to try fixing it (In this Order):

**
-Restarted Steam after ensuring the Steam.exe process was terminated.
-Restarted Computer
-Verified Integrity of Garry’s Mod game cache files.
-Deleted Entire Garry’s Mod and GCF archives, and re-downloaded a fresh copy, and verified the integrity and Defragmented Game Cache.
-Uninstalled Half-Life 2: Deathmatch, Half-Life 2: Episode One, Half-Life 2: Episode Two.
-Deleted and Redownloaded “winui.gcf”.
-Verified Integrity of Half-Life 2 game cache files.
-Defragmented Half-Life 2 game cache files.
**

**When I enabled the Steam Console, the console outputs the following error, the EXACT SAME ERROR that was being reported BEFORE redownloading the game:

**


Steam error:  SteamProcessCall(LaunchApp)(0xab134c,0x18cd44,0x18cc38) failed with error 1: Resource failed verification check
SteamLaunchApp() error:  SteamProcessCall(LaunchApp)(0xab134c,0x18cd44,0x18cc38) failed with error 1: Resource failed verification check
CJoinGameDialog::OnSteamError() : launch game failed, with steam error:
 SteamProcessCall(LaunchApp)(0xab134c,0x18cd44,0x18cc38) failed with error 1: Resource failed verification check
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Verifying the Integrity results in a 100% clear check, and nothing reports faulty. So I need some answers here.

Are there any other suggestions? I’ve done everything imaginable to try fixing it to play the game.

I really need help with this, it is still an ongoing problem.

Are you sure that you also ended hl2.exe?

Yes. 90% of the time that I turn on my computer, and start Steam from a clean boot, is just to play Garry’s Mod. I dont start any of the Half-Life series by themselves. When I tested these conditions that I mentioned in the main post, it was when the only program attempting to run, was Garry’s Mod, and the first First Time it tried running, was when it gave that error, from a clean re-installation to Vanilla Gmod.

As I type this, it has been over 3 computer restarts since my last testing, and I started up steam once more to try starting gmod, and it is still giving me the same error.

Did you buy Gmod? Also did you verify every game that helps gmod run. It some times solves my problem.

Yes of course I bought Garry’s Mod. And Yes I have verified every game. Every game that Garry’s Mod would attempt to mount.

EDIT:

Now… Now this is going too damn far. I mean WHAT THE HELL… All my other Steam games will run just peachy, but when I downloaded the old Gmod 9.0.4c to have some retro fun while I waited for the normal Gmod10 to just work, it gave the EXACT same error! IT IS A SOURCE MODIFICATION! NOT A STEAM GAME! How on EARTH can it POSSIBLY FAIL A RESOURCE INTEGRITY CHECK?!?!.

It is the only game/mod that is other than Garry’s Mod that is giving me a load of craptastic grief, I can’t even play the obsolete mod without being bothered with this bullcrap. I might just reinstall steam all together to see if it fixes it.

[editline]27th October 2011[/editline]

I would also like to take special note in saying that Portal 2 and Half-Life 2, Episode One, and Episode Two run just fine.

I would also like to note that Amnesia, Audiosurf, and all my other Steam games run just fine.

I would also like to make a note that I am running Windows 8 Developer Preview, and Garry’s Mod never gave me issues until this little crisis.

And one last note, I reinstalled Steam from SCRATCH and it still is giving me shit about the game not being ready. I need a major suggestion before I up and delete my entire SteamApps Folder and Redownload steam and reinstall the whole thing.

[editline]27th October 2011[/editline]

I am now completely uninstalling EVERY SINGLE Steam game, and eraticating the entire Steam folder and redownloading EVERYTHING, and the ONLY two games I will have installed are Garry’s Mod and Half-Life 2. If the game finds it reasonable to CONTINUE not working after deleting over 40 gigs of games to get it to work, then Screw you Steam, I will reinstall it in Windows 7 if it wants to give me such a goshdamn fuss.

Pardon my frustration. This has been a very irritating day, everything will be fine in the end I hope.

[editline]27th October 2011[/editline]

Update: Steam is now fully uninstalled. No traces of games or the steam folder exists. I will now start the re-installation procedure.

[editline]27th October 2011[/editline]

Another Update: Steam is redownloading Garry’s Mod and Half-Life 2 now, I will check back on its status later today in the afternoon. I do appreciate what help has been given, even though it has been about as fruitless as Heddy Llamarr’s Declawed Mouth.

Back, and it would seem that completely eraticating Steam fixed the problem with Steam, doing such cleared out any possibility of invalid files with either steam or HL2, which took out 2 variables at once.

You can lock / close this thread now.

Next time use Steam Support. They are the right people for these kind of things.

For future reference, I just deleted the clientregistry.blob to fix it.

I already tried deleting that as well as the other Steam directories, and started steam up to try once more, before reinstalling Steam from Scratch, and when it regenerated it, it wouldn’t fix the problem. I suspect Half-Life 2’s files were corrupt in some form or another and even after verification checks, it still would never actually fix the files.

But should the issues happen again later on, in a lesser severity, I will take your advice and try that first.