this happens whenever i shoot glass or anything else

that happens whenever i shoot anything…
i need help. I don’t know how to stop it from doing that

Woah, that hurt my eyes. Possibly something with your display driver? Is it up to date?

idk i will check

what is your graphics card?

Processor: AMD Sempron™ Processor 3100+, MMX, 3DNow, ~1.8GHz
Memory: 384MB RAM
Page File: 518MB used, 402MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode
it is just a stock graphics card, not a Nvidia or ATI graphics card

[editline]02:58PM[/editline]

i updated my display driver but it still didn’t fix anything

What do you mean stock? Integrated? If so, integrated sucks ass. Get a new graphics card. Or try putting “-dxlevel 80” in launch options.

yeah i ment integrated

There’s not really anything you can do to improve your situation if you’re using an integrated graphics card, sorry.