Tips for normal mapping in source sdk?

I’ve recently just begun experimenting with normal maps for maps created in hammer and I’ve noticed that all the normal maps I create with crazybump only appear when within a 2 foot radius around your character. I’m sure there is some setting I need to mess around to get them working properly. Any mappers here have any experience with creating bump mapped textures for their maps?

I don’t get what you mean by “appearing within a 2 foot radius”. Can you screenie that?

Normalmaps ($bumpmap in the .vmt) have always worked fine for me, also over larger distances.
Try to post your .vmt if you want me to have a look at it…

Here’s an example how it works for me:

	$basetexture	Wall/Blackwall_rough_2_diff
	$bumpmap	Wall/Blackwall_rough_2_nor
	$envmap		env_cubemap
	$envmaptint	"[.1 .1 .1]"
	$surfaceprop	rock

Do you have anisotropic filtering on?

In the game menu? I was using trilinear before and then switched to ansiotropic with no difference in how the textures appeared.

Here is how the test texture looks like, you can see how the effect clearly fades away after a distance.

and here is the VMT for Freakrules

The only thing that bothers me with your .vmt is why you have $color and $alpha and $selfillum because they’re pointless if you just leave them with default values. What do your flags look like on your actual .vtfs?

Should I just clear them out then? I just used another material file as a template, so I have little understanding of what those parameters do.

Here is what I have checked for the normal vtf,

normal map
eight bit alpha

the actual texture has no checks.

Try using this.
(In case you don’t want your texture to have a specular map, remove “$normalMapAlphaEnvMapMask” and “$envMap”.)

	"$baseTexture"			"patrick/yacht_deck"
	"$envMap"			"env_cubemap"
	"$normalMapAlphaEnvMapMask"	"1"
	"$bumpMap"			"patrick/yacht_deck_normal"
	"$surfaceprop" 			"Wood_panel"

Also, disable anisotropic filtering and normal map flags for your .vtf, as it may be causing the issue and normal map is not needed here.

The actual normalmap should have “normalmap” checked.
Also make sure the mipmap aren’t blurred.

On another note: Source uses a inverted Y channel in the normals, so instead of things in normalmap that should “pop out” looking like they do, they should look like they are “pushed in”, In nDo2 just use “Invert Y”.

great post man. worth plaudit.