Tired of Tool Gun Related Error Messages- Need Support

Problem Solved :slight_smile:

I’ve rented a server with XFactorServers and on my server, whenever anybody pulls out their tool gun they get this error (which rapidly spams the screen as long as the toolgun is out):

Regardless of the messages, nothing abnormal happens. No errors, no problems. Just annoying error messages.

I have the following addon’s on my server-

WireMOD
ULX and ULIB
PHX (I doubt this is the cause because it never happened when it wasn’t there)

All are updated to their latest versions.

ULX has been somewhat strange with me, sometimes certain ULIB files don’t load and on one occasion the commands such as “Enable noclip” and “Enable PvP” (entire world commands) would NOT work (fixed by resetting server).

Any help is wonderful.

Update wire.

Then you’ve either:

  1. Not installed it correctly.
  2. Got a conflicting addon.

go to

C:\program files\steam\steamapps<YourSteamName>\garrysmod\garrysmod

And rename the Garrysmod folder to GarrysmodOld.

then launch Garrysmod, if you have no errors upon launching, then close garrysmod

and install it using the wiremodsvn link

DO NOT copy the old wiremod file from GarrysmodOld

www.wiremod.com

Follow the link and go to the download page, follow the tutorial.

Well the problem isn’t in my WireMod, it’s in the server’s. I know this because everybody who joins the server has the same problem.

I’m about 99.9% positive that I installed it correctly too.

Any other ideas?

Contact the server owner and tell them to get their thumb out of their ass and reinstall wiremodSVN

Well at this point I’m assuming you didn’t read my first post carefully lol :stuck_out_tongue:

I’m the server owner, and MY server is what I’m trying to fix. And after updating WireMOD the problem persists.

And I don’t enjoy sticking my thumb up my ass, don’t worry about that. :smiley:

A bump as a desperate means of getting help.

No, the first thing that caught my eye was the errors on the picture, try reinstalling everything again thats all i can say, if not then try checkinig if its another addon on the server thats messing it up, you only really need

Wire
PHX
Weight
Boyancy

as addons.

Sorry i don’t know anything about servers on Garrysmod so if that doesnt work then maybe its the gamemode thats glitched or something.

Which SVN address are you using?
As I know the problem is Wire.

I’m sorry, but that error you’re getting is the exact same error everyone using wire had when they took out the toolgun after a gmod update a couple of months ago. Are you absolutely sure you’re updating wire from the right place?

BTW I fixed it.

I had set up a wire SVN and even though it downloaded, it didn’t download the latest update. There were a few files added on and it totally fixed the error.

Idiotic I know, but thanks a ton everybody.