Tool/Spawn Menu

I cannot seem to open the spawn/tool menu. i checked the binds, tried +menu in console, and nothing happens. i also noticed that this goes with not having the camera or tool gun, and not being able to give them to myself. this happened directly after starting to play zombie survival(noXious.net). my HUD is also now default. i would like not having to re-install or go through every single addon, so more ideas in those guidelines would help. thank you in advance.

specs:

Intel® Core™2 Duo CPU E8400 @ 3.00GHz
nVidia GeForce 9600 GT 512mb
1 gb ram/core
windows xp pro 32-bit

if you need my addons ask, dont feel like typing that much right now(5+ gb of addons)

one of your addons probably messed up the Q menu. Try deleting recent addons.

You’re probably in a Server where the Spawn Menu is disabled…
Like a RP one.
And I don’t think we need to know that much stuff about your computer just because the spawn menu doesn’t work xD

this is in single player, sorry for not saying that. i have tried it on diffrent maps that i know it works on also, with no luck.

Hmm.
Then IDK, have you “defaulted” your keyboard in Option > Keyboard > Restore Defaults?

no, but as of this post, i am no at my rig so i cont try, but thank you for saying that.

It’s most likely as stated before an addon.