Toolgun LUA error

I had this Toolgun LUA error after I downloaded these add-ons. I deleted the add-ons that It have may affected my Gmod. Now, I still get this LUA error. I do have the legitimate Garry’s Mod (Proof Below)

I tried reinstalling it by “Delete Local Content…”, but that didn’t seem to do the trick. Any Ideas? Help Appreciated.

Will post the error soon.

I can still use the toolgun, but the error is just too annoying.

Well your Gmod isn’t installed, that might be a problem, that combined with the fact you said you have a legitimate copy makes it seem like you pirated it.

Ontopic: We can’t exactly help you if you don’t post anything related to the error.

wire/client/toolscreen.lua:23: attempt to call upvalue ‘_ViewModelDrawn’ (a nil value)
^^^ Error

It was installed, I uninstalled it to reinstall it. Still have that error though. New pic Reinstalled.

It is legitimate. I can pull out my printed receipt out of my wallet right now and take a photo if you want me to.

Garry updated GMod and broke the tool gun. Wait a day or so, it will be fixed.

Oh gee. Thanks :slight_smile: . What site do you use to get the latest news on Gmod?

Edit: Just found Garry’s Blog and Garry’s Mod.com . Thanks again. Thought I broked my Gmod.

Yup i updated wire mod svn, and started getting all these errors. I had been playing on a server about 10 minutes before and the server was being updated so i went to single. Thought my updating wire mod caused it and then realized that gmod had just updated.

Went on my favorite server and the Q menu & C menu were completely broken, wouldn’t even open. Along with the spam of LUA errors up my anus.
Then looked online and found that this latest update was more of a Fail-date.
V_V Sad daaayy

My error? easy precision tool broke. For singeplayer. Keeps saying “Tool: No constraint to remove”

I’m getting the same exact error. I’ve since tried deleting anything that has to do with easy precision and cleaning my addons out, performed the usual steam side fixes (uninstalling and cache related options) but to no avail. Does anyone have some help for this problem?


(User was banned for this post ("Dumb bump" - Gran PC))

i can understand getting bad marks for bumping a very old thread but im extremely desperate. Please help if you can. If my comment was dumb then would you please be able to help me @ItsThatMatt?

You’re obviously using an old revision of the script and don’t bump old threads.v