Totally messed up spawns

I’m running Hunt RPG and Cornucopia, that’s the only things that would affect my spawn

Rock nodes are not respawning at all…I put Cornucopia on because chests weren’t respawning at all in Rad towns, animals weren’t respawning properly, etc.

Did I mess something up, or is spawning just broken right now? I’m not sure how I set something to mess things up, would be happy to learn!

Your servers ok?

Does it happen on unmodified servers? Because if not, it’s likely a plugin somewhere that’s doing it, and that’s up to the modding community to sort out.

Sup!

I’m the author of Cornucopia. Questions like this would be best asked on the Oxide site in the plugin’s discussion thread.

Cornucopia without a proper config could cause this issue. Please link your Cornucopia.json file for review, I’ll let you know if there is anything wrong with it. Also, make sure you have the latest version, there was a bug in a previous version that would cause issues like that.

You can do /cdump and check the RCON log for current node count on the map.

Edit: You say you installed Cornucopia because you had an issue to begin with — so the problem might not be Cornucopia at all. There is a console command which I forget which can affect or stop the spawning of game elements like this, if you toyed with it, you might want to go back to the stock value.

Sorry, I didn’t put it over there because I honestly don’t think it’s a plugin issue at all.

I’ve run several servers, don’t think I’ve ever used any console commands that tweak any base values…honestly didn’t know that was a possibility.

Here’s my .json:

{
“Animals”: [
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 25,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/chicken.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: -1,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/horse.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 40,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/boar.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 45,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/stag.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: -1,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/wolf.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: -1,
“Prefab”: “assets/bundled/prefabs/autospawn/animals/bear.prefab”
}
],
“ApplyLootFix”: true,
“Loots”: [
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 35,
“Prefab”: “assets/bundled/prefabs/radtown/loot_barrel_1.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 35,
“Prefab”: “assets/bundled/prefabs/radtown/loot_barrel_2.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: -1,
“Prefab”: “assets/bundled/prefabs/radtown/oil_barrel.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 35,
“Prefab”: “assets/bundled/prefabs/radtown/loot_trash.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 35,
“Prefab”: “assets/bundled/prefabs/autospawn/resource/loot/trash-pile-1.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 30,
“Prefab”: “assets/bundled/prefabs/radtown/crate_normal.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 30,
“Prefab”: “assets/bundled/prefabs/radtown/crate_normal_2.prefab”
}
],
“Ores”: [
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 95,
“Prefab”: “assets/bundled/prefabs/autospawn/resource/ores/stone-ore.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 95,
“Prefab”: “assets/bundled/prefabs/autospawn/resource/ores/metal-ore.prefab”
},
{
“DeleteEmtpy”: false,
“IgnoreIrridiated”: true,
“Max”: -1,
“Min”: 95,
“Prefab”: “assets/bundled/prefabs/autospawn/resource/ores/sulfur-ore.prefab”
}
],
“RefreshMinutes”: 15,
“RefreshOnStart”: true,
“FixLoot”: false
}

Looks good, that said 95 of each is insanely low compared to what you would naturally get. On a 4k map you usually get 300-500 of each type of rock (which is imho too much). Check with /cdump and rcon to see your count.

so I went with the new HapisIsland map to see what it was like, do those numbers still apply? I can’t find anywhere saying how large that map is.

I usually do the 4k procedural map, maybe if I can’t get this nailed down I’ll just re-roll next patch

Yeah I suppose so, you’ll want them to be at least 2-300 each for Hapis.

Just do /cdump and check RCON you’ll see how much of everything you have. That’s a Cornucopia admin-only command.

Yeah, my numbers on what I have now match up what I have in the config file, that’s no worries. I just didn’t have the settings right to preserve the initial spawn, i.e. server build time spawn, to know what was those numbers are “supposed” to be

So. If I’m that far off, that explains a lot :slight_smile:

Thank you!