Trouble In Terrorist Town major issues

Hello, I’ve got all of TTT to work but a few things, I’ve got the portforwarding done (I imagine thousands of threads have been posted about the portforwarding) and everything.
The Problem:
In the gamemode, If a traitor purchases a C4, and attempts to “use” “e” it, nothing happens, no ui about planting. I’ve tried multiple restarts, friends have tried to arm with no luck, there’s no others with this problem, it outputs no errors.
I’m sorry about posting here, I understand i’m not supposed to but there’s no Garry’s Mod issue discussion, and any threads about people having problems appear to be in this category.
I hope I’ve given as much detail as possible, and that somebody is able to help me.
Thanks

Have you placed the CS:S folder in your orangebox folder? I had the same issue.

I’ve just copied it to there, I’ll have to test it when i have a freind on the server as i can’t play alone, i’ll post the results here

You can play alone by using the commands ttt_minimum_players 1 and ttt_debug_preventwin 1 in the rcon, you’ll always be a traitor and are free to test.

Works great, thanks for the help!