Trouble Installing Addons

Hello, I’m having some difficulties installing particular addons to garry’s mod. With ones such as the Nuke Pack 4 or Osama NPC, there is just one folder in the zip file to copy to the addons folder. However, with ones such as the citadel_destroy map that I am trying to add, there are multiple folders titled “maps” “materials” etc. I’ve tried adding them all to the addons folder, and adding them to there respectively named folders in the garrysmod folder. When I did the latter, the map worked but the materials still did not. There are just a bunch of purple and black squares everywhere. Please help me with this issue. Thank you.

After you downloaded and opened with winRAR or something:

  • mark all these “material”,“maps”…etc. folders
  • rightclick-copy
  • set “…/STEAMUSERNAME/garrysmod/garrysmod” as target and simply click OK. winRAR should ask you now, if you want to put them in the same-named-folders. Click OK of course.
  • ???
  • profit!

I’m going to jump on to this and ask my question. What if I can’t see/find the steamusername/garrysmod/garrysmod file? It’s the Steam version of GM for the Mac if it makes a difference.

how do i get garry s mod add on ?

“/Library/Application\ Support/Steam/SteamApps/<STEAM USERNAME>/garrysmod/garrysmod” is the exact path for mac users. If there is no “<STEAM USERNAME>/garrysmod/garrysmod”, you can’t have the playable legal version of gmod.

To you, and to gman 2117’s weird question above: It’s much easier to google “gmod addon installation”, instead of waiting for an answer here