Trouble Mounting Content to Linux (Ubuntu) Gmod Dedicated Server

This seems to be a very old question, and seems to have been solved a thousand times for a thousand people from the threads I’ve searched, but I just cannot figure it out. My mount.cfg looks like this:



// 
// Use this file to mount additional paths to the filesystem 
// DO NOT add a slash to the end of the filename 
// 
 
"mountcfg" 
{ 
    "css"        "/home/bin/content/css" 
    "tf2"        "/home/bin/content/tf2" 
    "dod"        "/home/bin/content/dod" 
    "hl2"        "/home/bin/content/hl2" 
    "l4d2"        "/home/bin/content/l4d2" 
} 


My server is located in /home/bin/server_1/
No matter what I’ve done, I cannot get the content to mount. Suggestions? Help? Please haha… I’ve never hosted a server on linux before, but I’m learning more and more each day. Thank you in advanced for any advice I can be offered.
P.S I have also tried moving my content to /home/bin/server_1/garrysmod/content/ but came to no solution. I have also attempted putting cd ~ before the first / and tried removing the / all together.

It’s not “css” “tf2”, it’s “cstrike” “tf”

Does that really matter?? :suicide:
Can you give me an example of the first one?

What?

Just redo the first mount. For example, set up the css one so it is what it should look like. Just so I know for sure.

Firstly, what’s in your css folder?

I just realized that cstrike was in the css folder. I feel so stupid right now, but regardless of that, after adding /cstrike to the end, it still doesn’t work.

Did you rename “css” to “cstrike” as well? Should be


    "cstrike"        "/home/bin/content/css/cstrike"

Sure did. I actually removed the /home part too, I found out that when browsing files in the terminal, it doesn’t recognize /home as a directory. It recognizes /bin though.

[editline]15th December 2013[/editline]

I found this post and it definitely works as a way around it. This is what solved my problem:
http://forum.facepunch.com/showthread.php?t=1276199&p=40933453&viewfull=1#post40933453

Now all of my content is mounted.