Trying to add a sound for a TTT map but ambient_generic wont let me select mp3..

I’m trying to put a song into a TTT map, but i cant because the ambient_generic doesnt let me select a sound file. The options are disabled. Heres what that looks like:

http://img547.imageshack.us/img547/5126/r6bv.png

Any way to fix this? So I can search sounds?

Convert it to a .wav

I dont think thats what it is though. The Sound File text box is completely disabled. I cant even add any sounds or anything.

You need to use the filter textbox to find what you’re looking for, and it has to be a .wav

I converted the sound file but its still not showing up. Am I supposed to move the sound to a certain folder?

And the “Sound File” textbox still is disabled. I learned to always find your file through that…

Edit:

http://img534.imageshack.us/img534/1073/zhge.png

The circled area is what I am talking about. I need to use the sound file textbox to search for the .wav file i need to import but its disabled.

You need to put your sound file in the sound folder of the game your working on. If there is not a folder named sound, just create one. It’s also a good idea to create a subfolder inside sound called custom. That way you can easily find your custom stuff.

Restart Hammer. You should then see it in the list.

Change Game Sounds to Raw like so

http://puu.sh/5A6qr.png

Fairly sure that’s all you have to do if you’ve placed the mp3 file correctly.

Also you can’t playback mp3 files within hammer so you’ll have to test it in game

Just had a quick look at the music from hl2. You may also want to make sure the sample rate is correct. The music from hl2 is as follow:

Sample Rate: 44100Hz
Bit Rate: 123 Kb/s

As long as you encode your mp3’s to these settings and you place them in the sound folder. You should be set. Remember, Hammer won’t play back MP3s. But they should work in-game. You can test them by using a logic_auto.

Any time I convert anything to a .wav the file size is enormous. This is extremely useful

Thank you very much!