Trying to redirect Game Data to a new location on a other drive

Note I accidentally screwed the title up, and I try to point Hammer the new location of my game data

I recently picked up a Intel SSD for free, because it was used, I wasn’t sure how long the drive would last, and therefore I left the Windows installation on my Seagate drive intact.
I wanted to pick up mapping again, but since I moved it over to a new location, Hammer refuses to launch when I load it from Half-Life 2\bin directly, and gives the following message:

Note the location of HL2’s Hammer is at E:\Stoma\SteamApps\common\Half-Life 2\bin\hammer.exe now

So far I verified all of my Half Life 2 games, I tried to edit the game configurations using the Source SDK (Bad move), which did no avail.
No matter how much I try it KEEPS seeking with the ordinary path.
I tried to launch the Hammer version in E:\Stoma\SteamApps\common\SourceSDK\bin\source2009\bin, which gives me two error prompts simultaneously.

http://i.imgur.com/x2rsPSL.png[/T]
And the missing file is present:
[T]http://i.imgur.com/PGrSiIz.png

I have been trying and trying so far, I really want to pick up mapping again after a sudden inspiration blast, but it just refuses to work.
I really hope somebody knows a answer to this shit.
Thanks a lot in advance if you know a potential answer.

[editline]5th July 2014[/editline]

Here’s some other news, I managed to get the Hammer version in the Source SDK bin working, but it crashes really fast, and misses the scheme file. I tried putting a file related to the schemes in SourceSDK\bin\source2009\bin\resource, which only removed the prompt but still leaves me with broken viewports, so I guess that one is a no-go

Try the source multi tool
http://forum.facepunch.com/showthread.php?t=1327883

Maybe it will ale you on your journeys

Well, for some reason the program crashes when trying to launch with the following details


Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	source multi-tool.exe
  Problem Signature 02:	1.0.0.0
  Problem Signature 03:	52bdddde
  Problem Signature 04:	System.Windows.Forms
  Problem Signature 05:	4.0.30319.18408
  Problem Signature 06:	52311103
  Problem Signature 07:	14ed
  Problem Signature 08:	5d
  Problem Signature 09:	System.ArgumentOutOfRange
  OS Version:	6.1.7601.2.1.0.256.1
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


I installed the latest .NET framework, then this happened.

I’m thinking that source may not let you run the sdk or hammer unless its on the same drive as steam.

Please be aware that there is a known issue with source multi tool and multiple drives. It’s an issue with the tool itself not hammer.

The VDC should have some information on this:

Well I just used a solution which is one big bypass of the issue.

I just installed Windows 7 on my old laptop, use synergy to link it between my computer and the laptop and off you go.
But still, I want to find a decent solution for this, as this laptop is over four years old now.

Use mklink in cmd, I use it to link my entire steamapps folder to another drive off my ssd.

Dang that sounds better than I did.
Can you give a example of this command? I use mklink /d D:\Stoma\Steamapps C:\Program Files (x86)\Steam\Steamapps but I get a incorrect argument, guess I didn’t do this correctly.

I normally use junction for this, ex: mklink /J “C:\Program Files (x86)\Steam\SteamApps” “E:\Steam”