TTT Advanced End Round Music F1 Menu Not Work

	local function AddSettings( dtabs )
		local musicsettings = vgui.Create( "DPanelList", dtabs )
		musicsettings:StretchToParent( 0, 0, padding, 0 )
		musicsettings:EnableVerticalScrollbar( true )
		musicsettings:SetPadding( 10 )
		musicsettings:SetSpacing( 10 )

		local setting = nil
		local Music = vgui.Create( "DForm", musicsettings )
		Music:SetName( "End Round Music" )
		setting = Music:CheckBox( "Enable End Round Music", "ttt_eor_music_enabled" )
		setting:SetTooltip( "Disable EOR Music" )

		musicsettings:AddItem( Music )

		dtabs:AddSheet( "EOR Music", musicsettings, "icon16/music.png", false, false, "End Round Music Settings" )
	hook.Add( "TTTSettingsTabs", "AddSettings", AddSettings )

Original Code:

The F1 Menu Portion doesn’t work you can’t turn off the end round music. Can someone help with a fix please.

What have you tried? We aren’t going to spoon feed you, and considering you haven’t posted any errors we can’t really help you.

There are no errors its just when you press f1 and check mark box and such it doesn’t work. Also, did you even try the code to see what I mean’t at least instead of just instantly commenting. If you tried it you would notice there are no errors, the check mark button doesn’t work so you can’t disable end round music

Most people here don’t try code, it’d take so long to try everyone’s code and people have their own stuff too

My original post explains the problem I mean that is literally all I got the code works except the f1 menu check box part when u uncheck it it doesn’t disable because when it is checked it enables. No Errors.

I’m not trying your code. It’s your job to provide us with what’s happening.

I ask again, what have you tried to fix it?

I have tried nothing because I have no clue how I would fix it because literally the code appears by looking at it to work but it doesn’t

Are you sure your script even check if your settings is set?

It’s not my script it’s someone elses and others have the same problem and nobody got it fixed for them so I’m hoping someone here on facepunch has a solution. So I don’t know I’m not a good lua scripter.

I doubt people are going to make it for you here, might happen but I’d just go to ScriptFodder

There has to be someone who is knowledgeable to understand the code and notice where the problem is.

There is, but not everybody wants to do it for free. I have better things to do myself, but that’s just silly me.

Just so you can stop expecting us to spoon-feed you, look for ttt_eor_music_enabled.

That’s the ConVar that’s being set, make sure it’s being checked properly.

I’m not expecting you to spoon-feed fyi, I’m asking you to point out a line that is creating the error then I can figure out the fix probably on my own.

If it’s not providing you with an error, do you expect us to magically know? Most of us aren’t going to be bothered to run the code, considering it’s just that - code. I personally am not going to go out of my way to install an addon, and try to debug it for you.

Look for the ConVar, and attempt to figure it out.

Ok, well I look through it and it all makes sense to me. Nothing appears to be in the wrong spot. I also compared it with TTT Damage logs that code and it’s fairly similar so I don’t see why it wouldn’t work.

Quite interesting…

Same issue for the last 2 years the convar works(as in it changes) but it does absolutely nothing to stop the music.

usermessage.Hook( “stop_preround”, function( um )

	if GetConVar( "ttt_eor_music_enabled" ):GetInt() == 0 then
	local ply = LocalPlayer()
	if and IsValid( ) then
end )

usermessage.Hook( “playurl”, function( um )

	local url = um:ReadString()
	local volume = um:ReadLong() / 100
	local isEOR = um:ReadBool()
	if isEOR == true and GetConVar( "ttt_eor_music_enabled" ):GetInt() == 0 then
	local ply = LocalPlayer()
	if and IsValid( ) then

if ( CLIENT ) then

CreateClientConVar( "ttt_eor_music_enabled", "1", FCVAR_ARCHIVE )


I can't find any reasons it doesn't work