TTT Developer Needed

Hi, I currently own the Thunder Gaming TTT server and recently Iv’e been wanting to make come changes to my server. Unfortunately I don’t know how to configure and code that much and I need someone with basic knowledge to help me find and add some script to my server. If you can help or know anyone who can help please let me know and we can work something out on Steam.

What do you need? It may be able to be done for free if it’s simple. (Or, at least part of what you want.)

I need help with adding weapons to my point shop. As well as adding the hands of player models to the model when you buy it. And finally adding a double jump feature buy able to donators only, I have the addons for this I just need to configure it. Thanks!

For the double jump Im guessing you’re using the one by Willox on the workshop?

Edit:
I’m going to go with yes as I don’t believe there are any others out there. Here’s some code for double jump (remember to change the config in the double jumps config file) and simple perma weapons:



ITEM.Name = 'Double Jump'
ITEM.Price = 15000
ITEM.Model = 'models/items/hevsuit.mdl'
ITEM.SingleUse = false
ITEM.NoPreview = true

function ITEM:OnEquip(ply, key)
	ply:SetNWBool( "can_double_jump", true )
end


function ITEM:OnHolster(ply)
	ply:SetNWBool( "can_double_jump", false )
end





ITEM.Name = "Deagle"
ITEM.Price = 1500
ITEM.Model = 'models/weapons/w_pist_deagle.mdl'
ITEM.SingleUse = false
ITEM.NoPreview = true
ITEM.WeaponClass = 'weapon_zm_revolver'

function ITEM:OnEquip(ply)
	ply:Give(self.WeaponClass)
end

function ITEM:OnHolster(ply)
	ply:StripWeapon(self.WeaponClass)
end

function ITEM:PlayerSpawn( ply )
	if ply:Alive() and ply:Team() ~= TEAM_SPECTATOR then
		ply:Give(self.WeaponClass)
	end
end


OK so I added both things to my server. They showed up in the pointshop but when i went to buy them they didn’t work. The gun didn’t go into my inventory and the double jump didn’t work correctly. I saw somewhere that something had to be added to the entities folder. Maybe that is the problem.

Did you not have any other weapons that occupied the inventory slot before you equipped the weapon(s)?
If I recall correctly with pointshop in TTT, it won’t give you the weapon unless you don’t have anything in that particular slot. Also, if you have the deagle equipped and spawn on/with a pistol in the map, it might not give you the weapon either.
Atleast, that used to happen on the TTT server I was a dev on. Try to re-equip it in case that happens and see if you do get the gun.

For the double jump, like you said, try adding those files to that folder. The only thing the pointshop file does is allowing you to equip/unequip it.
Also, if you only want donators to be able to buy the double jump, you might want to add


 ITEM.AllowedUserGroups = { "donator" }

to the double jump file. Replace the word donator with whatever your donator group is called.

OK adding the files worked. Unfortunately it works for the entire server instead of only being activated when it is bought in the shop. Maybe there is a config file inside that only allows to to be activated through point shop or something. Also with the perma weapons I’m gonna try a M9K weapon that is not set on random spawn to see if that works.

[editline]13th October 2015[/editline]

Also when I tried to buy the Deagle I didn’t have anything in that slot.

Edit the actual file to only allow a certain usergroup to use it. Then allow that same usergroup only purchase rights in pointshop

That isnt the issue, he means when one person equips it, the double jump works for the entire server (Had the same issue when I first tried this.)

To OP: I now assume you’re not using the double jump by Willox, I would suggest using it as its pretty good and thats the only one (That I know of) that the pointshop file I gave works for.

And for the deagle Im not quite sure why it isn’t working for you.

You don’t need the last function, OnEquip is called whenever the player spawns anyways.
Also Item.SingleUse is defaulted to false so no need for that either

In fairness I made that when I was fairly new to coding.

I mean that the jump works for the entire server, regardless is one person equips it or not.

You are probably using a global value/variable instead of using ply.whatever
What code are you using?

I’m not exactly sure there are a bunch of codes inside the addon. Not sure which one does what. If anyone wants to you can add me on steam and ill give you the ftp and see if you can do it, because I know i’m doing something wrong XD