TTT Gamemode Timer failure

Note: My server has addons, and is not vanilla

Past two weeks my dmg logs began to fail after my server randomly crashes (yes I fixed the player.say (hook) error so that’s not the problem), but it fixes itself after 2 or 3 map changes. Its completely random, and I got no clue why this is occurring. Among all the errors, I believe the culprit is because of the TTT gamemode timer fails.
When this occurs players are able to kill each other before the round even starts, and dmg logs do not record anything let alone register a round has started.


Timer Failed! [prep2begin][@gamemodes/terrortown/gamemode/init.lua (line 493)]

L 06/17/2015 - 16:11:57: Lua Error: 
[ERROR] addons/utility - damagelogs-master/lua/damagelogs/damagelog_events/misc.lua:28: Tried to use a NULL entity!
  1. old_func - [C]:-1
   2. SetNWBool - addons/utility - damagelogs-master/lua/damagelogs/damagelog_events/misc.lua:28
    3. unknown - addons/utility - damagelogs-master/lua/damagelogs/ulx/sv_autoslay.lua:149

A parse for the init.lua file I currently am using

I have been having this issue ever since I updated my cl_keys.lua and gamemsg.lua with the updated one from https://github.com/garrynewman/garrysmod/tree/master/garrysmod/gamemodes/terrortown/gamemode

From all the research I have done, “typically a timer will fail if the function inside it is unrecognizable, or if it errors, syntax, etc”.

This person has had this issue, but not specifically for damage logs back in 2013 so it may be irrelevant…
http://forum.facepunch.com/showthread.php?t=1321897

I have also gotten this error a week ago, but it has not turned up in a while since then.



[ERROR] addons/utility - utime/lua/autorun/cl_utime.lua:310: attempt to index local 'cpanel' (a nil value)
  1. buildCP - addons/utility - utime/lua/autorun/cl_utime.lua:310
   2. resetCvars - addons/utility - utime/lua/autorun/cl_utime.lua:305
    3. fn - addons/utility - utime/lua/autorun/cl_utime.lua:334
     4. unknown - addons/ulib/lua/ulib/shared/hook.lua:179
Player|STEAM id number] Lua Error:
controlpanel.Get() - Error creating a ControlPanel!
You're calling this function too early! Call it in a hook!

I got no clue what is causing my server to crash, let alone have the the timer fail.
Iv searched through github, and facepunch and I’v only been able to find one person with a similar issue.

Please help, because I am utterly blank on how to solve this.

I was wondering if anyone else has had this issue also.

Do this: 1. Reinstall your TTT gamemode from the GitHub here: https://github.com/garrynewman/garrysmod/tree/master/garrysmod/gamemodes/terrortown
2. Remove the Damage Logs.
3. Reinstall ULX/ULib and UTime with it from their respective repositories.