TTT Hud Disable

Im having a problem disabling the default TTT hud



function ttt_draw()
   -- Just to make sure this is running
   draw.RoundedBox(0, 0,0, ScrW(), ScrH() / 2, Color(255,255,255,255) )
end

local hide = {
    ["CHudHealth"] = true,
    ["CHudBattery"] = true,
    ["CHudAmmo"] = true,
    ["CHudSecondaryAmmo"] = true,
}

hook.Add( "HUDShouldDraw", "HideHUD", function( name )
   if ( hide[ name ] ) then return false end
end )

-- This is being called and working
hook.Add("HUDPaint", "TTT_CSGO_HUD_Paint", function()
	ttt_draw()
end)


Fix:
I found out why this wasn’t working. I was running a outdated version of TTT. So if your having a problem with disabling the default. try updating your version of TTT. :slight_smile:

TTT uses custom elements that you’d need to hide. You can find a list of them here.

If you want to disable the normal HUD while alive, you’ll have to use “TTTInfoPanel”.

okay so i have this



hook.Add( "HUDShouldDraw", "HideHUD", function( name )
   if name == "TTTInfoPanel" then return false end 
end )


and it still didn’t disable the ttt hud

There might be another hook with the same identifier, try changing that. Also, note that hiding that, only hides the info panel on the bottom left (when alive).

I know whats all i wanted to do.

I found out why this wasn’t working. I was running a outdated version of TTT. So if your having a problem with disabling the default. try updating your version of TTT. :slight_smile: