TTT Pointshop Player models issues

Howdy folks,
I just opened a TTT server, and added pointshop on it. Now I’m having some issues with playermodels.
Practicly at the start of a new round playermodels get resetted to the default one, so I have to hostler & equip it again to have the skin of [Ezio Auditore Assassin’s Creed player model]
After various researchs I found out that I have to edit the player_ext.lua folder at line 271. Results?
Bugs. Bugs and bugs again.
First of all the round won’t start, even if there are players on the server (the Waiting status won’t turn), even if I did !unspec *, a text will come out saying “Waiting for players…”.
Then I tried adding ttt_color_mode 0 to server.cfg and also ttt_minimum_players 1.
So I started spawning after that, but the results were: No arms, buggy gameplay, also players with default skin had the grey playermodel thing.
The errors shown up in console are the following:
[ERROR] gamemodes/terrortown/gamemode/player.lua:22: attempt to call method ‘InitialSpawn’ (a nil value)

  1. unknown - gamemodes/terrortown/gamemode/player.lua:22

No such variable “$phongtint” for material “models/weapons/c_arms_citizen/c_arms_citizen_sleeves”
Error: Material “models/weapons/c_arms_citizen/c_arms_citizen_sleeves” : proxy “Clamp” unable to initialize!

Error: Material “materials/cable/cable_rendermode_0” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_1” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_2” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_3” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_4” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_5” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_7” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_8” uses unknown shader “SplineRope”
Error: Material “materials/cable/cable_rendermode_9” uses unknown shader “SplineRope”
No such variable “$phongtint” for material “models/kleiner/players_sheet”
Error: Material “models/kleiner/players_sheet” : proxy “Clamp” unable to initialize!
No such variable “$phongtint” for material “models/kleiner/players_sheet”
Error: Material “models/kleiner/players_sheet” : proxy “Multiply” unable to initialize!
No such variable “$phongtint” for material “models/kleiner/players_sheet”
Error: Material “models/kleiner/players_sheet” : proxy “Clamp” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_phoenix”
Error: Material “models/cstrike/t_phoenix” : proxy “Clamp” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_phoenix”
Error: Material “models/cstrike/t_phoenix” : proxy “Multiply” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_phoenix”
Error: Material “models/cstrike/t_phoenix” : proxy “Clamp” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_leet”
Error: Material “models/cstrike/t_leet” : proxy “Clamp” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_leet”
Error: Material “models/cstrike/t_leet” : proxy “Multiply” unable to initialize!
No such variable “$phongtint” for material “models/cstrike/t_leet”
Error: Material “models/cstrike/t_leet” : proxy “Clamp” unable to initialize!
Error: Material “cable/cable” uses unknown shader “SplineRope”

If i add back the line 271 of player_ext.lua everything works smoothly. Helps?

Cancel out line 272, not 271 (line numbers changed after update)

Worked kindly! Thank you. Since I’ve opened this thread, may I ask a new question? Why do I see my weapons with violet glows in certain maps? It’s not server’s problem, btw.

Hmm, this is a new one. Is CS:S mounted on the server?

Probably because there is missing textures somewhere on the map causing the missing texture glow out from something.

Well it’s just my problem, not other’s players problem. Anyways, last question. I have a plugin for ttt weapons, but the issue is that special equipments gave are placed in slot 10 instead of slot 8, as every ttt weapon (That you could equip by pressing V)
Since the plugin has been downloaded from the pointshop it’s a .gma file. What’s to do in that case?

Extract the .gma using GMad and edit it.

Wich string do I have to edit?

SWEP.Kind.


-- Kind specifies the category this weapon is in. Players can only carry one of
-- each. Can be: WEAPON_... MELEE, PISTOL, HEAVY, NADE, CARRY, EQUIP1, EQUIP2 or ROLE.
-- Matching SWEP.Slot values: 0      1       2     3      4      6       7        8
SWEP.Kind = WEAPON_EQUIP1

Done. I tried to edit the jihad sound also but it didn’t work. Sorry if I make so many questions but I’m just a beginner. After I exctract it, now, what do I have to do? to add it again as .gma file in addons section?

Just put the legacy folder in addons. Don’t recompile it into a .gma.

SWEP.Kind = WEAPON_EQUIP2
Done that. Doesn’t work. Jihad gets on slot10. Any ideas?

Post the code in


 tags; slot 10 doesn't even normally exist.