TTT server - Bad RCon PW

When I try and use RCon Password it always says that it’s a bad password. I have set it and I know the password but it doesn’t seem to work. I also have lost my rank, I need to use the server console to get it back and it doesn’t work.

lol.

anyway do this rcon_password PASSWORD. example rcon_password youarereallystupid

I did that…

Then it is wrong password.

[editline]18th October 2013[/editline]

Try in server.cfg do this rcon_password “snorlaxisright”. Then changelevel or restart doesnt matter. then is console: rcon_password snorlaxisright

It will work

I’ve done that and it still doesn’t work.

Are you sure that you all the words is lower case? and you are not making any typo´s?

I’m sure.

No idea what is wrong then? Can i see your server.cfg.

HINT : Replace your real rcon password with something else then you post it

//
// garrysmod\cfg\server.cfg
//
// This is the main configuration file for your server.
// See the following URL for more information:
//
// http://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/indexebfc.html#Example_Server_Config_File
//
// Changes to this file require a restart.
//
// Last Modified: 23 June 2013
//

// Server Name
hostname “[DD]Dench As Drench”

// RCON Password (Remote Console Password)
rcon_password “Password”

// Server Password (Connect Password, “” for nothing)
sv_password “”

// Game Log Settings
log on
sv_logbans 1
sv_logecho 1
sv_logfile 1
sv_log_onefile 1
sv_cheats 1

// Gamemode and Sandbox Cvars
sbox_godmode 0
sbox_noclip 1
sv_noclipspeed 20
sv_noclipaccelerate 5

// Gamemode Limits
sbox_maxprops 150
sbox_maxragdolls 5
sbox_maxnpcs 10
sbox_maxballoons 10
sbox_maxeffects 50
sbox_maxdynamite 10
sbox_maxlamps 20
sbox_maxthrusters 30
sbox_maxwheels 20
sbox_maxhoverballs 20
sbox_maxvehicles 6
sbox_maxbuttons 20
sbox_maxsents 20
sbox_maxemitters 5
sbox_maxspawners 3
sbox_maxturrets 2

// Fast DL Settings (DO NOT CHANGE!)
net_maxfilesize 30
sv_allowdownload 0 // 0=FastDL Enabled, 1=FastDL_Disabled
sv_allowupload 1 // 0=User uploads disabled, 1=User uploads enabled
sv_downloadurl “http://95.154.240.141/897/Gmod/

// Loading screen settings
// To use custom loading screen, comment out the default one and uncomment
// custom one. Loading screen can be edited using ‘Config File Editor’.
// sv_loadingurl “http://friendscape.host22.com/Photos/welcome.html
// sv_loadingurl “http://95.154.240.141/897/loading/
sv_loadingurl “http://jimbobplatt.wix.com/denchasdrenchttt

rcon_password “snip”
sv_defaultgamemode “terrortown”
sv_scriptenforcer “1”
sv_password “”
sv_region “255”
sv_lan “0”
sv_alltalk “3”
ttt_minimum_players “1”
ttt_karma_max “5000”
ttt_karma_clean_bonus “300”
ttt_spec_prop_force “200”
ttt_idle_limit “120”
ttt_det_credits_starting “3”
ttt_det_credits_traitorkill “1”
ttt_karma_low_amount “500”
ttt_karma_round_increment"50"
ttt_highlight_admins “1”
ttt_postround_dm “1”

// Settings
sv_region 3 // https://developer.valvesoftware.com/wiki/Sv_region
sv_lan 0 // 0=Internet (default), 1=LAN only

// Dev log option set to 1 to log LUA errors to file
lua_log_sv 1

// Execute Ban Files
exec banned_ip.cfg // Ban IPs
exec banned_user.cfg // Ban Users

“sv_allowdownload” “1”
“sv_allowupload” “1”
sv_downloadurl “https://dl.dropboxusercontent.com/u/195596605/Gmod/Maps/

[editline]18th October 2013[/editline]

Just noticed I have 2 PWs -___- I am dumb.

Erm… Just a quick question… You do own the server right? you say you lost your rank… Any server owner with an iq of 70 would know how to add himself back.

In what would just posted, the rcon password would be snip (seen as it as the last one executed)

You mentioned 2 times in the server.cfg = ofc your password doesnt work

Shouldn’t make any difference. “snip” would be the rcon password, it wouldn’t make it not work.

<----------------------------- dis guy stupid

If you use a batch file to execute your server, make sure that it is not included in the parameter for running srcds.exe, and make sure you’re typing “rcon_password pass” into console. If you type something else, it will sometimes say “rcon password invalid” even if you have the invalid syntax.