TTT Server Hangs on Addons Completed

On a Trouble in Terrorist Town server I play on, when trying to connect I encounter one of two things. The loading either hangs on Addons Completed or “downloading someicon.vmt.bzt” and it causes me to lose several minutes of playtime. It’s not a huge problem but it’s a definite inconvenience. I know that nobody else gets this error, and I also know that none of my addons are conflicting nor do I actually have the negev.vmt on my drive. It shouldn’t be an internet issue because my ping to the server sits at around 35 and my download speed is 7MB/s, but I load in after a friend with 70+ping and 256KB/s because of my downloads hanging.
I’ve tried reinstalling Garry’s Mod, verifying game cache and deleting my downloads folder. Nothing worked.

Any help is appreciated.
Thanks in advance!

I still have this issue, even when there are no downloads. Don’t know why, but in my experience, it takes longer to load if you are tabbed out.

I do tab out, but it’s because of how long it takes to load, not the other way around.