[TTT] Server lag when over 20 players

Hello,

I’ve recently setup a TTT server running on a VM. The VM is on a dedicated ESXI server with an Intel Xeon E3-1245V2, 16GB RAM and a gigabit NIC. At the moment, the GMod server is the only VM running. It has 2 vCPUs and 4GB RAM assigned to it.

When the player count gets above 20 players begin to experience movement lag. This occurs most noticeably at the start of a round once the preparation timer hits 0, but is intermittent throughout the duration. I’ve checked resource usage on the VM when this occurs, RAM isn’t above 50% and the overall CPU utilisation sits around 30% (core #1 hovers around 50%, core #2 around 10%).

I’m running in the region of 65 addons, the majority of which are maps. The only addons to the actual game mode are ULX and around 10 additional weapons.

I’ve attached my config below, off the back of the lag experienced, I’ve lowered the tick rate from 66 to 33 but it has made no noticeable difference.

Any guidance would be very much appreciated.



hostname ""
rcon_password ""

ttt_firstpreptime 60
ttt_preptime_seconds 30
ttt_posttime_seconds 13

ttt_haste 1
ttt_haste_starting_minutes 5
ttt_haste_minutes_per_death 0.25

ttt_round_limit 4
ttt_time_limit_minutes 30
ttt_always_use_mapcycle 0

ttt_minimum_players 2
ttt_traitor_pct 0.25
ttt_traitor_max 13
ttt_detective_pct 0.13
ttt_detective_max 7
ttt_detective_min_players 5
ttt_detective_karma_min 800

ttt_karma 1
ttt_karma_strict 1
ttt_karma_starting 1000
ttt_karma_max 2000
ttt_karma_ratio 0.001
ttt_karma_kill_penalty 15
ttt_karma_round_increment 5
ttt_karma_clean_bonus 30
ttt_karma_traitordmg_ratio 0.003
ttt_karma_low_autokick 1
ttt_karma_low_amount 600
ttt_karma_low_ban 1
ttt_karma_low_ban_minutes 20
ttt_karma_persist 1
ttt_karma_clean_half 0.25

ttt_postround_dm 1
ttt_no_nade_throw_during_prep 0
ttt_weapon_carrying 1
ttt_weapon_carrying_range 50
ttt_teleport_telefrags
ttt_ragdoll_pinning 1
ttt_ragdoll_pinning_innocents 0
ttt_use_weapon_spawn_scripts 1
ttt_spawn_wave_interval 2

log on
sv_logbans 1
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

sv_lan 0
sv_region 3
net_maxfilesize 100

ttt_playercolor_mode 0
ttt_highlight_admins 0
ttt_detective_hats 1
ttt_spec_prop_control 0

sv_crazyphysics_remove 0
sv_crazyphysics_defuse 1

exec banned_user.cfg
exec banned_ip.cfg

sv_timeout 90

sv_minrate 0
sv_maxrate 20000
sv_minupdaterate 16
sv_maxupdaterate 33
sv_mincmdrate 16
sv_maxcmdrate 33

Thanks,
Kazakus.

In game enable the net graph with “net_graph 1” in console. When the server lags does anything in the net_graph window change or dip below what a number it’s normal at? From what I can tell when the text lerp starts getting yellow it’s due to the servers cpu maxing out. If packet loss increases is could mean not enough bandwidth.

Also, TTT isn’t well optimized, you might want to profile the gamemode and tweak it yourself.

Check all yours addons with https://steamcommunity.com/sharedfiles/filedetails/?id=682765484
And delete the useless addons from tour server.
It’s maybe surcharge of CPU you Can use : https://steamcommunity.com/sharedfiles/filedetails/?id=793317003
Tickrate : 25
And test value of netcode on your server