TTT Soundscape Issue

Hey guys, I have been facing this huge problem for the past few days and have come to no resolution so here it goes.

I added soundscapes to one of my WIP ttt maps few months back and found they functioned perfectly fine in sandbox, yet did not work in the trouble in terrorist town gamemode. I ended up just pushing soundscapes further down in the production line and proceeded to work on other components of the map. Now that things are beggining to come to a close, I have come face to face with the problem again but this time a little closer to fixing it, yet not quite.

For the sake of ease, Here is the current state of the problem in bullet points:

  • Soundscapes work perfectly fine in sandbox, yet not all soundscapes are correctly registered and/or triggered in the ttt gamemode.
  • In ttt all 3 soundscape entitiy types are detected and they do trigger soundscapes, but only a few entities are detected at any given time, even when I am completely next to where one is located.
  • ‘env_soundscape_triggerable’ are also detected, and the ‘trigger_soundscape’ brush is registered when I enter ‘report_entities’ into the console, but when I collide with a ‘trigger_soundscape’ brush linked to a soundscape_triggerable, the soundscape does not trigger and the event is ignored. (this is not the case in sandbox)
  • Due to trigger_soundscapes not functioning, I have decided to revert exclusively to using env_soundscape’s and env_soundscape_proxy. The problem now is that, with soundscape_debug enabled, some soundscapes are detected from a distance yet not up close, while some others either function normally or not at all.

Here is what I have tried so far:

  • Cordon off differing sections of the map and disabled area portal’s (If I cordon’d off enough of the map pretty much all soundscape entities would function, disabling area portals had no effect.)
  • Hid practically all point entities excluding soundscapes and compiled (The results were a little better, but the problem was still extremely apparent.)
  • Did fast, full and final compiles with cordon enabled (full/final compile had minimal effect.)
  • Double checked for typo’s in custom soundscape script and soundscape entities.
  • Tested a combination of env_soundscape’s, env_soundscape_proxy’s and env_soundscape_triggerable’s to see if they yield the same results (they did.)
  • Analysed the behaviour of soundscape entities with “soundscape_debug 1” in both the TTT and Sandbox gamemodes (As stated earlier, the soundscape entities all functioned fine in sandbox, yet in TTT most would dissapear as I approached them or not appear at all.)

Last but not least, a few questions:

  • Are there any compile/console commands I could try to have further clarity over the issue or approach a solution?
  • Is there anything I could try/tweak with the ttt game files to solve the issue?
  • Has anyone else experienced this problem?
  • Is there anything I may have missed?

Please update me on whether this is something purely on my side, or they also have the same behaviour on your side.

If anybody needs something from my end, be sure to let me know! Any input is welcome. (Oh and sorry for another help thread, the problem was getting pretty urgent.)

You’re the creator of Rooftops, correct? I remember talking mapping with you on steam awhile back!

Anyways, it’s not just you. Soundscape issues have been hindering my progress for a long time, and I ended up putting those issues on the backburner just like you.

For me, soundscapes behave differently in multiplayer than they do in single player mode. For example, if I run my map in the TTT gamemode in singleplayer mode, soundscapes function just fine. However, if I run my map on a server, the soundscapes are all messed up. They end up playing random soundscapes rather than the ones I’ve created and specified.

This problem also isn’t confined to just my map. Any TTT map I play in multiplayer has the soundscapes all messed up. I’ve searched around and asked for help on the issue multiple times but still haven’t gotten it figured out, even after a clean Gmod install.

It’s been bugging the hell out of me. :confused:

I’m experiencing the exactly same issue. Unfortunately, I had to replace the soundscapes with a globally playing set of ambient_generic (which are pretty crap for that).
We should get someone to fix it in the upcoming GMod update.

Possibly an engine bug of some sort then? Hopefully enough attention could be drawn to the issue to get it fixed. It completely ruins the ambiance I’m trying to create for my TTT maps.

Edit: Found your GitHub thread you created about this issue, TFlippy. Kinda disappointed it hasn’t had much activity at all since October. :confused:

Apparently it appeared after the Steampipe update and doesn’t occur in TF2 as far I know.

So the problem is global, damn. I guess the least we could do is raise awareness, I have seen barely anything on the problem aside a forum post or two. From the looks of it I might end up sticking to a single soundscape or ambient_generic as well. :S

I will continue to look for a workaround, but I doubt one would be found within hammer. Oh and please, if anybody with knowledge on the topic has a crazy idea that could even be considered a bit of a stretch, speak up. At this state, anything is acceptable. (there’s no loss in trying)

I may just leave my soundscapes the way they are and hope that the bug is fixed someday. I simply cannot get the job done by throwing together some ambient_generics.

Maybe this deserves a new GitHub bug report? Seeing as TFlippy’s report has had minimal activity.

Sure go ahead, the more reports the better.

You could head over to the Next Update thread in Developer Discussion, as I recall Soundscapes being mentioned as broken in multiplayer, however I swear there was also a post saying they got fixed

Made a post regarding it on the thread, thanks for the suggestion.

I also posted in the Next Update thread, and also created a new GitHub issue. I’ve also reported something else I’ve noticed: Door closing sounds specified in “func_door” and “func_door_rotating” entities function fine in single player, but are broken in multiplayer. On any type of server, the doors make sound when they open, but are silent when closing, even with a closing sound specified.

So the new issue I made got closed because it was a duplicate of TFlippy’s issue. :v: