TTT store glitch (won´t open)

Hello, my problem is this.
Everytime i try to open the traitor/detective store, it will pop up the “something is creating scrips errors”. when i check on console this appears:

[ERROR] lua/includes/extensions/string.lua:87: bad argument #1 to ‘string_len’ (string expected, got boolean)

  1. string_len - [C]:-1
  2. Explode - lua/includes/extensions/string.lua:87
    3. unknown - addons/advancedeqmenu/lua/eqmenu.lua:236
    4. unknown - lua/includes/modules/concommand.lua:54

somebody knows how to fix this?

Does this happen on every server? If not then its serverside meaning your client files are not the problem.

idk, i have not play in others ttt servers, but a friend of mine played on the same server and it was able to open the store

addons/advancedeqmenu/lua/eqmenu.lua:236
Is it a leaked Advanced Equipment Menu?

well i played in another server and it worked

Tell that server owner to stop using leaked addons done.

Leak addons? could you explain yourself, please?

Moved to developer section - Brockerman when they say you’re using leaked addons it’s copies of paid scripts that you downloaded for free.

Sometimes they’re out of date/have backdoors.

check if you don’t have any weapons that aren’t in ttt base and remove all addons and put one by one testing if it works, eventually you will find the addon that fucked up the menu

it’s boring maybe but it works

i deleted the addons, but i dint work. still won open

Reinstall gmod, you fucked up the server home how if you deleted all add-ons and errors persists

NVM, that comes from your advanced equipment add-on, delete that one and it will work

If your friends can open it then its you? Just remove the addon and uninstall it if its installed on the workshop section. If that doesn’t work then just go on steam and verify the integrity of Garry’s Mod