[TTT] ULX crashes server upon slaying all

I make too many topics about server crashing.

Anyway, my server crashes upon using the !slay * command in ULX. Odd thing about this crash is that there are no errors whatsoever, it just kicks all players from the server and the server just freezes.

This crashing is a problem because it will happen when players are on the server just playing the game. I’ve tried numerous things to fix it, such as getting rid of all addons besides ULX, and yet it will still crash.

I have no idea what this type of crash means, but if anyone had any kind of similar problems and could point me to somewhat of a fix I’d be very grateful.

EDIT: Forgot to make it a little more precise.

Server will crash pretty randomly while using the slay command. It will also crash regardless if using a command or not. My players will be running around playing the game normally and the server will just crash in the same way that it would when the command does it.

We don’t fix add-ons, we help you with code you have problems, I recommend you to go into ulx forums and try to find help there since I imagine ulx developer is more active there

It’s technically not the addon itself, at least I don’t think. It happens regardless of the slay command, the slay command just speeds up the process. I should probably change the title…

I will try over at the ULX forums too. They might have some info or what not.

Yeah, but you’re misunderstanding my post, i said we only help people with code they have problem with, not with crashes, server issues, addon issues or anything else they didn’t build (And server management is not developing)

To be fair if people come in with an attempt at their problem, whether it’s some code they tried or different things they’ve tried to fix their problem - I’m sure most of us won’t have a problem helping them.

However it’s when they don’t try that nobody wants to help them, because why help someone who just wants to be spoonfed?

Further testing made me realize that the CPU usage spikes up to 100% randomly, that’s good.

I believe it’s been solved. :slight_smile: