Tutorial Getting a model/prop into the Source engine.

I found this videotutorial for getting a simple box into Source engine in the forums of the goldeneye mod for hl2. Step by step and very easy even for newbies in modeling like myself.

YOUTUBE LINKS (Low quality):

Part 1:

Part 2:
[media]http://www.youtube.com/watch?v=n1R4Wu5F6NY[/media]

Part 3:
[media]http://www.youtube.com/watch?v=VdIvfO35sKc[/media]

Part 4:
[media]http://www.youtube.com/watch?v=XnOX-aIMAno

HIGH QUALITY (WMV FILES):

Part 1:
fileden.com/files/2007/3/25/923698/Part_1.wmv

Part 2:
fileden.com/files/2007/3/25/923698/Part_2.wmv

Part 3:
fileden.com/files/2007/3/25/923698/Part_3.wmv

Part 4:
fileden.com/files/2007/3/25/923698/Part_4.wmv

Hope this come in handy for anyone interested and sorry for my english from spain.

Yeh i made this tutorial lol. My friend just gave me a link saying that my tutorial had been posted on another forum. It’s nice to see that my tutorial has been noticed =-P

If anybody needs further help then just add me to msn or send me a PM.

MSN: Armoured-Fury@Hotmail.co.uk

I also know how to animate and get animated props in game and i think i may make a tutorial about it i dunno yet lol.

I hope this tutorial helps people as it seems to be helping folk so far.

Correct YouTube links lol.

Part 1:

Part 2:

Part 3:

Part 4:

Yup, when I saw the the Making a Simple box, I knew straight away it was Armoured’s tutorials. They work perfectly, i’ve used them for my college project so far.

Where are those files mentioned in the tutorials? The reference model and the SMD compile addon?

Edit:

Also, I have made a model and I’m trying to compile it into Garrysmod, but I do not know how to set up Garrysmod in Source SDK. I set it to Half-Life 2: Episode Two and set the directories to garrysmod/models and garrysmod/materials/models. The GUI Studio MDL program has since frozen though. I’m doubting this works properly for garrysmod?

The tools that you need are to the right of video 1, there is a link. It should also work in Garry’s mod =-/

for gmod, just make the model and texture normally and the put them in gmod’s models and materials folders and poof = model

Nice tutorial man, really helpful.

but I’m stuck on the part where you compile. Whenever I start the compile it just gives me this error :ERROR:could not load file ‘clown.obj’

here is my QC file:

$modelname “/clown.mdl”

$cdmaterials “/clown”

$scale 1.0
$surfaceprop “Metal”

$body “Body” “clown”

$staticprop

$sequence “idle” “clown_idle” fps 30

$collisionmodel “clown_phys”
{
$mass 100
$concave
}

All the SMD files are on my desktop in a folder named clown.

I fallowed all your instructions, the only thing I did differently was i set the compile for Ep2 and had different names for my smd files.

Why are the .SMD files on your desktop? They have to be in the respective folders in your Source installation directory. Are you saying that you made a shortcut to the directory on your desktop or that you made a folder on your desktop and put the .smd files into it?

The .smd files must be in the right folder(s) because you’re telling the compiler where to look, in your .QC file so it will look where you tell it to look. If the files aren’t there then it will give you an error message…

Ah, I see.

Well I changed the directory in which the compiler must look for the files and it’s still giving me that error.

$sequence “Idle” “C:\Documents and Settings\User\Desktop\clown\clown_idle.SMD” fps 30 ACT_IDLE 1

$collisionmodel “C:\Documents and Settings\User\Desktop\clown\clown_phys.SMD”

It would be better to put this:


$cd "C:\Documents and Settings\User\Desktop\clown"

Than to include it in each of the SMD references.

so this should work:


$cd "C:\Documents and Settings\User\Desktop\clown"
$modelname "clown.mdl"
$scale "1"
$body body "clown.smd"
$cdmaterials "clown"

$surfaceprop "metal"

$sequence idle "clown_idle.smd" fps 30

$collisionmodel "clown_phys.smd" {
$mass 100.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}

(re-wrote it off my base version as there was lots of un-needed stuff in yours, don’t use $concave unless you have to and $staticprop is only EVER needed for maps, and even then not often).

Also if your not making a ragdoll you may aswell just use the reference smd (in this case clown.smd) as the sequence and collision model as well, as it saves you saving the same thing more than once and does exactly the same thing (unless your collision model is made specially for some reason).

That worked, thanks.

but now I have another problem. My model is invisible when i try to view it in the model viewer.

np :slight_smile:

Its invisible? Thats rare with non-hexed models. Have you converted your texture files into VTF and VMT files? (i’d suspect you have). If you have got VMT files check they have “VertexlitGeneric” at the top and not anything else like “LightmappedGeneric” thats what usually causes invisible models.

Yeah that fixed it.

Thanks again.

np :slight_smile: Thought it might be that :stuck_out_tongue:

Is there one for blender? I just don’t have the $3000 quite yet. :frowning:

Well, blender is not done for gmod riging, you could still try but it’s a pain to assign everything. You could still download 3ds max trial or milkshape. The best software for prop is 3ds or blender but for ragdoll it’s 3ds. Dvondrake tutorial on blender is pretty useful for that kind of stuff.

Well I’ll be damned, 3DS takes up 20GB of HD space, which I don’t have, and Milkshape isn’t for OSX. :<

some should upload a vavle skeleton in .blend because I get strange thing while importing. The bone are not triangle but they are kind of tube with 2 sphere.

My textures are Pink and black in model viewer, I pasted my Texture files in like 25 different locations >.<
Help mehhh.

this is my QC file:

$modelname “5bill/model.mdl”

$cdmaterials “models/5bill/”

$scale 1.0
$surfaceprop “wood”

$body “Body” “5bill”

$staticprop

$sequence “idle” “5bill_idle” fps 30

$collisionmodel “5bill_phys.smd”
{
$mass 100
$concave
}

and this is my GameInfo file

“GameInfo”
{
game “Garry’s Mod”
title “”
title2 “”
type multiplayer_only

	"developer" 		"TEAM GARRY"
	"developer_url" 	"http://www.garrysmod.com/"
	"manual"           	"http://www.garrysmod.com/wiki/"

	FileSystem
	{
	SteamAppId				218
	ToolsAppId				211
		
	SearchPaths
		{
C:\Program Files\Steam\steamapps\moniquekalb\garrysmod\garrysmod
C:\Program Files\Steam\steamapps\moniquekalb\half-life 2\hl2
C:\Program Files\Steam\steamapps\moniquekalb\sourcesdk
		}
	}
}

Please help me :P!!
Thanks,

Are you sure you have all your materials in the “materials/models/5bill” folder and that all the VMTs there point to the right VTF?