Two merged meshes causes a difference in lighting.

http://i.imgur.com/2UFuXhf.png[/t]
[t]http://i.imgur.com/pm14STQ.png[/t]

So, how can I avoid this lightning error? I’ve tried smoothing, but it doesn’t seem to affect it. I don’t model much.

It’s fine with lighting disabled.
[t]http://i.imgur.com/d45qgD0.png

Oh also, I am working on porting some Adventure Time characters. That should be fun.

If anyone know how to disable lighting on characters, that would help too. Maybe a shader or something?

If you wish to fully disable lighting on that model you can use the UnlitGeneric shader for that. Also make sure to turn off flashlight illumination with $receiveflashlight 0.

There are probably duplicate vertices in the area you are having trouble with. Try welding the vertices along the shared edges of the two meshes, and then redo the smoothing groups in the area after welding.

I’m not familiar with how to disable lighting…

I got the sulution over PM yesterday. The problem was solved using welding as suggested here.