ULX Causing Lag Spikes on New Machine

This is a known issue from
https://github.com/TeamUlysses/ulx/issues/59 and
http://forum.facepunch.com/showthread.php?t=1327932

Our server just switched from shared hosting to a dedicated server, and this problem is pretty bad right now.

Whenever a player joins there is a large lag spike, and there is also just constant lag. Removing ULX fixes this.

I tried a version from 2013 and it definitely helped but the lag is still noticeable. This wasn’t happening on the shared host but it is on the new machine.

Could anyone provide some insight as to what’s happening here? I’m looking to switch to Serverguard but am a bit short on cash at the moment.

Plenty of other admin mods to choose from.

I’d like to stick with either ULX or Serverguard because they’re the most compatible with other things and it’s what everyone is used to. I shouldn’t have to switch because of this problem.

I tried Maelstro but it’s not compatible with blogs and I can’t afford to get new logs right now.

This has been reported before, I just tested it and it works for me.

Please open a ticket and I’ll troubleshoot this with ya

If you’re currently short on cash I don’t mind giving you a free trial of ServerGuard for a while.

I heard somewhere using windows server fixes this

You should use windows server it’s faster and less bloated. Also powershell is much more powerful than bash. Also windows server is like windows and you don’t have to type because typing is difficult. Edit: plus i dont know linux so windows is better

I’ve bought SG, I made a thread on the forums about it only making it worse.

[editline]7th November 2016[/editline]

Update: It’s now happening with no addons at all.

Could “[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.” be contributing to it? I’ve tried for hours to fix that and I haven’t been able to.

I also noticed it started lagging with 25 bots on, is 2 cores of an E3-1240 v2 not enough power for an average 64 slot DarkRP server?

It could possibly just be an overloaded CPU or virtual cores not being set appropriately. The virtual cores could be different cores from a different CPU if it’s a virtual server. Essentially, if there is one physical core which is split into two virtual cores, then the server might use just half of the power of one core. E3-1240 is quite an old - End of Life - CPU as well. Since a GMod server session can only utilise one core, it’s important to have a relatively strong core for your GMod server rather than many not so strong ones. I would recommend that you try to monitor your CPU activity some and contact your host to explain the issue to them.

yeah mr sweepy boy if you use windows server it doesnt lag



 ______
< aids >
 ------
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||



(User was banned for this post ("Shitposting" - Novangel))

We have access to two full cores of that CPU. When the server is running the usage fluctuates from 20% to 100% on both cores seemingly randomly. The host is simply a VPS provider so I don’t think they’d offer support for this issue.



 ________________________________________
/ maybe you should use windows server mr \
\ sweepyboi                              /
 ----------------------------------------
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||


specs of your server? tried allocating more memory?

We’ve solved this by upgrading to a more powerful server, it just seems to be fairly CPU intensive for lower end processors.