ULX/ULib Errors on my server - [NEED HELP !]

Hello everybody !

I rencently got a big error on my server that broke my darkrp server I don’t know where it came from, so I started another server the only thing I saved was the server’s addons. So when the other server was up, I just copy pasted my addons and BOOM, when I try to put myself as a superadmin, It prints me this error in the console :
(By the way, I’m using ULib 2.6 (zip) and ULX 3.70 (.zip) (Requires ULib v2.60+))

KeyValues Error : LoadFromBuffer : missing { in File In
KeyValues Error : RecursiveLoadFromBuffer: got } in key in file InAddonInfo,

Here are a couple of scrennshots on postimg :
(I think I’m not enough experienced in lua or somethin’ to find the solution alone, so please help.)

Error message :

http://postimg.org/image/y85918ifx/

In-Game (I don’t have much admin commands which is not normal) :

http://postimg.org/image/7yr48t0qv/

So, what does that ? If you need more infos, tell me, I’ll try to tell you more.

Contact me and help me (please) : http://steamcommunity.com/profiles/76561198154202207/

Thank you, good night.
:smiley:
-iTechGaming

One of your ULX / ULib configuration files in data/ is fucked up and needs to be rewritten.

How do I rewrite it ? I redid my server twice and it didn’t work…

Move or delete all of the files in your server’s data/ulib and data/ulx folders, then restart your server. Also make sure you’re running the latest versions of ULX and ULib: http://ulyssesmod.net/downloads.php

If you cant find help here, try posting on the official ULX Forums:
http://forums.ulyssesmod.net

Hello guys ! Thanks for your replies! Both gmod updates should have been doomwnloaded automatically. If a hook or sething broke how do I fix it ? Also, now I get a new error :

[ERROR] addons/ulx-v3_70/lua/ulx/modules/cl/motdmenu.lua:237 : ‘end’ expected <to close ‘function’ at line 227> near ‘enÉ’

  1. unknown - addons/ulx-v3_70/lua/ulx/modules/cl/motdmenu.lua:0

[ERROR] lua/includes/extensions/net.lua:32: Received bad RPC, invalid function (ulx.rcvMotd)!

  1. func - [C]:-1
  2. unknown - lua/includes/extensions/net.lua:32

[ERROR] lua/includes/extensions/net.lua:32: Received bad RPC, invalid function (ulx.showMotdMenu)!

  1. func - [C]:-1
  2. unknown - lua/includes/extensions/net.lua:32

(Here you can see an image of the error in my console : http://postimg.org/image/hacxw1k97/)
(Also, notice that I don’t have much commands as a superadmin)

Looks like we made a step forward ! :smiley:
But I still have this error.

Hopefully you manage to help me again xD !
Thank you :smiley: !

Go to your motdmenu.lua file, go to line 227 search for the end of the function which should be after Line 237 and add a “end” in there.

Woah- your file got partially corrupted or something. As Desasterx3 said, open addons/ulx-v3_70/lua/ulx/modules/cl/motdmenu.lua, replace ‘enÉ’ on line 227 to say ‘end’.

Or, (safer bet), try redownloading ulx from here: http://ulyssesmod.net/archive/ulx/ulx-v3_70.zip
Or download from this URL if that still doesn’t work: https://github.com/TeamUlysses/ulx/archive/master.zip

Oh wow enE was the end… Totally overread that.

I already tried redownloading ulx and ulib and it didn’t work.

On line 227 I got this : function ulx.generateMotdHTML()

–So there’s no enE at the end, only in the console it’s weird.
(You can see an image of it here : http://postimg.org/image/ix0v0cui9/)

Here a screen of what error pops up in the console :
http://postimg.org/image/8lfqbvknl/

Should I put a end at the end of the line 227 ?

Thanks guys ! :smiley:

The end should be near the end of the file, on line 273. Still not sure why it’s gone though…

Use this as a comparison to how your file should look:

Hello, I have no more errors, but I still have no commands as a superadmin. I don’t know if it’s related but when I switch weps there’s no sound.
(here’s a screenshot : http://postimg.org/image/wawj3lfd1/)

Here’s a screenshot of my commands : http://postimg.org/image/dbkptdgnv/
Also looks like there’s nothing missing in my lua files.

Thank you! :smiley:

Not sure but arent that all of the Ingame Scoreboard commands?

Yes, but when it use to work, I had all commands on scoreboard !

[editline]25th February 2016[/editline]

[editline]25th February 2016[/editline]

I get new errors its weird :frowning: http://postimg.org/image/fse93okr1/

That just means those ports are in use by something. What else is running on the server if you are self hosting, or if you are not, you need to talk to your game host

I am selfhosting, so how do I fix this ? And do you know about the other big ulx problem :D? Thanks m8!

Alright guys by trying and trying again and again (means reinstalling and redoing my server) it worked ! :smiley:
So thanks guys :smiley: !

Nice thing!
Hope you could learn a bit.

I learned and relearned that you never fail until you stop trying :smiley:
(Also make a bit of changements then test it)