ULX Website Ban Display

I am new and I am not sure how this works but here I go anyways.

This was an old ULX remote ban system. Can anyone get it working for 13 because its out of date?

Did you get any errors when using it? If so please post them.

I had it on a website, but it did not display any banns.

Edit: http://www.thecardtricktutor.com/bans That’s what it looks like, there are banns in the file, just not showing. I have in looking at /garrysmod/data/ULib/.

So can anyone set this up for 13?

I wasn’t able to test the update function (since I didn’t want to link it to my server).
But the script it self worked fine for me? Take a look here:
http://diplons.com/custom/test/

I think the whole problem is linking it to your server. I got it like that before because that’s the bans it comes with.

When I link it to my FTP bans in the ulib/bans it shows nothing.

[editline]22nd November 2012[/editline]

http://www.thecardtricktutor.com/bans/

All I did was add the files, it does not even show the bans already there but the are in the folder.

What configuration did you do to the file to make it show like that?

I just tested it with my server linked. It actually works, but I had to set file permissions for bans.txt to 777 (other values untested).
Although it doesn’t shows anything, but that’s because my bans are using another format.

Sorry for my stupidity but what do you mean by “set file permissions for bans.txt to 777”.

I mean you need to set chmod to 777.
Ehm…
If you are using Filezilla, right click on the bans.txt file and select “File Permissions”.
In the text field write 777 (or check all the boxes) and press OK.

I added the files, made the right FTP, user, pass, and I did 777 for the bans.txt.

I am out of options.

And it still doesn’t work?

-Are you sure you wrote the right path in $ftp_directory located in the config.php file?

/garrysmod/data/ULib/

[editline]22nd November 2012[/editline]

Like I said, when I upload the file alone I don’t even see the pre-bans.

[editline]22nd November 2012[/editline]

http://diplons.com/custom/test/

What did you do to get it looking like that?

Step by step?

I downloaded the zip file you posted.
Extracted it and uploaded all the content of the “bans” folder to http://diplons.com/custom/test/
I right clicked on the bans.txt folder through filezilla and clicked “File permissions”
I checked all the boxes in the window and pressed okay.

Now the steps to make it able to update the bans
I edited the config.php file with my info. To get the right informations to $ftp_directory,
I located the ulib folder on my server in filezilla and copied the directory path shown above the remote file tree.
After I’ve changed the config.php file I upload it to the folder with the other content.

In my case it didn’t show any bans after the update because my bans was saves like this:



"STEAM_0:0:17211740"	
{
	"unban"	"0"
}


Where the script only read bans like this:



"STEAM_0:0:5251314"	
{
	"time"	"1310587356"
	"unban"	"0"
	"name"	"Duck Source"
	"admin"	"+[SP]+[P.G] Russy(STEAM_0:1:17489103)"
	"reason"	"Hax0r"
}


Bro, thanks for the help, but I think its a problem with my web host because it will NOT work.

I did every step.

Thanks for trying.

What is the exact $ftp_directory in the config.php?

$ftp_directory = ‘50.31.22.70:21/garrysmod/data/ULib/’;

$ftp_directory = ‘50.31.22.70:21/garrysmod/data/ULib/bans.txt’;

$ftp_directory = ‘50.31.22.70:21/garrysmod/data/ULib/bans’;

I have tried all of these.

Its almost like my page is not saving.

Are you sure you should add the ip with the port? I mean, it all depends on the access you have, but mine is this:
/home/myserver/gmod/orangebox/garrysmod/data/ulib/

I got root access, that explains all the folders…
But you should find the ulib folder with filezilla, and while you are in it copy this

Paste the path in the $ftp_directory variable so it would be like this


$ftp_directory = '/home/myserver/gmod/orangebox/garrysmod/data/ulib/';

Just with your path

I got it!

Host problem, the website would not edit.

I got it up but the thing is I get this error, any help plz?

http://s17.postimage.org/gnsdnnsbz/New_Picture_23.png
photo storage

Were you using the like I gave you?

That was made for my bans -_-