Unable to host gmod server..

Just for the record, I have hosted, succesfully, CSS servers on the same box in the past.

Whenever I try to start my gmod server I get some errors and whatnot…



ScriptEnforce is disabled
Compressing lua files into data pack..
Skipped. Datapack exists.
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient.dll. Continuing with current version anyway.
Failed to load Steam ServiceServiceStart: failed to start*********************************************************
*       Unable to load Steam support library.*
*       This server will operate in LAN mode only.*
*********************************************************


This is my script for starting the server…
I’ve also tried with, and without +port 27015 +ip 192.168.0.4, also with/without -secure



#!/bin/bash
echo "Starting up Garry's Mod 10 server."
sleep 1
cd /home/eivind/srcds/orangebox/
screen -AmdS gm10server ./srcds_run -command update -game garrysmod -verify_all -dir . +map gm_construct
echo "Started. Type screen -x to resume!"


This is my config file…



hostname                "Blabla"

rcon_password           ""
sv_password             ""

sv_region               3
sv_lan                  0

log                     on
sv_logbans              0
sv_logecho              1
sv_logfile              1
sv_log_onefile          0

sv_noclipspeed          5
sv_noclipaccelerate     5
sv_downloadurl "http://"
sv_allowupload 1
sv_allowdownload 1

// Bandwidth settings
sv_minrate 5000
sv_maxrate 20000
decalfrequency 60
sv_maxupdaterate 60
sv_minupdaterate 25

// GMOD
sbox_godmode            0
sbox_plpldamage         1
sbox_noclip             1
sbox_maxprops           150
sbox_maxragdolls        4
sbox_maxnpcs            10
sbox_maxballoons        10
sbox_maxeffects         50
sbox_maxdynamite        60
sbox_maxlamps           20
sbox_maxthrusters       30
sbox_maxwheels          80
sbox_maxhoverballs      30
sbox_maxvehicles        10
sbox_maxbuttons         60
sbox_maxemitters        30
sbox_maxspawners        30
sbox_maxturrets         10

net_maxfilesize         255

// execute ban files
exec banned_ip.cfg
exec banned_user.cfg


I’ve also tried starting my CSS server, and apparently I get the same error…
I’m pretty new when it comes to debian, but I don’t see how I could get any errors coming from that side…
My ports are forwarded.
And I recently changed my ISP, I haven’t tried hosting a source server on the debian box since I changed my ISP.

Thanks in advance for any responses!