Unable to include another Lua script?

I’m currently working on a STOOL, but I’ve decided to seperate it into seperate Lua scripts as they were getting quite lengthy. But, whenever I try to include a file in my STOOL’s Lua, it claims it can’t find the file. However, I was under the assumption that includes can either be relative to the file or to the Lua directory. When I try to run it with lua_openscript, it can find it perfectly fine, and it outputs exactly what I’m expecting it to output, namely a string and a table address. The respective console outputs:

Couldn’t include file ‘derma.lua’ (File not found) (@addons/vem/lua/weapons/gmod_tool/stools/vem.lua (line 6))

Running script derma.lua…
base
table: 0x2d5cf520

My derma.lua is in the root Lua directory of my add-on, so I figured I would be able to include it with


include('derma.lua')

But, to no avail. I quintuple-checked it by skimming through other people’s code. What’s going on here?

Did you AddCSLuaFile(“derma.lua”) on a serverside file?

It’s on line 5, to be exact. Temporarily commented it out for the sake of testing, but enabling it again gives me the same error as before plus:

[AddCSLuaFile] Couldn’t find ‘derma.lua’ (@addons/vem/lua/weapons/gmod_tool/stools/vem.lua (line 5))

[editline]17th May 2013[/editline]

Moving it all to a new add-on folder seems to have solved it. Very weird.