"Unable to load 'filesystem_steam.dll' error" - We don't need other threads on this. - Seriously, no more threads.

I’m pretty much trying to get my client to startup when I get the following error…

“Unable to load garrysmod\bin\filesystem_steam.dll”… Unable to start it up.

Hey, same with me. I was playing Gmod just fine only about an hour or so ago, and suddenly I exit and start up again, but get the exact same error.

Reinstalling Gmod doesn’t seem to work for me. No idea what would cause this.

Probably some kind of recent quickfix that fucked shit up.

Again.

Yep. Seems Garry botched a loading routine in the .gcf, and that’s fucked up the client.

Guess we all gotta wait on a fix.

Same here.

Yea, same here.

Mother fuuuuuuuuuu. . . another problem within what, two months?

I think everyones out of luck

Its 03:48 right now in britian, I dont think garry updated anything, Was most likely Valve.

god dammit garry, i got finals tomorrow and wanted to unwind before bed… FIX NAO PLZ, KTHXBAI

You guys realise there was just a source engine update, and this problem is probably the effect of that, and not Garry’s fault.

Perhaps you guys should actually get some facts right before crying and whining about how it’s Garry’s fault. I’m sure Garry’ll get a patch out sometime in the next few days.

Damn you steam, you fucked my night over!!!

it seems my attempt at being a 13 year old girl worked, now to be serious, so it is a source engine update i’m hearing? oh well, crap happens

He will most likely patch it tommorow morning with his usual


Time: Get up, noticed a steam updateo
Time: Realised gmod is fucked, Need to recompile with the new update
Time: Hit a snag in the compile, need to rethink this through with coffee.
Time: The update has compiled.
Time: Sent the update to valve, Just up to them now.

Yea, I was about to have a fun night, but now someone messed up on something…

you got beaten by the person under you, they have a few years experience though.

Shit, I was just about to make a thread about this. At least I know I know it’s not just me…

Same problem here. I actually researched the issue for roughly an hour, because I installed some things earlier. Thought they messed up my system. Glad (well, not really) to see it’s happening to others.

at first i thought i might have done something, but i noiced that it was updating so i put 2 and 2 togeather and i thought that the update must have broke the game (again)

so looks like we will have to wait untill garry can patch the game.

Same thing is happening for Counterstrike: Source.