Unable to load manifest file - HLMV

Hi!
After one year I decided to go back to SourceSDK. I downloaded everything what is necessery, but I have problem with game_sounds_manifest.txt file when I run HLMV from Source SDK. I don’t even have scripts folder in common/half-life 2/ep2.

I’m fighting with this since yesterday, and still have that error. It happend when Valve moved their games into SteamPipe, before that everything works fine.

  • I launched each game (HL2, HL2Ep1, HL2Ep2) at least one time,
  • changed/removed SteamAppId line,
  • used “Reset game configurations” option in Source SDK
  • verified game files many times,
  • reinstalled HL2 Ep2 and Source SDK,

I tried to find solution in web, but I found nothing.

The Source SDK isn’t really officially used anymore. You’re better off using the tools located in “common\Half-Life 2\bin”. Some of them are a bit fiddly to get to work for the first time, but once they’re set up, you should have an issue after that.

I don’t want to create another topic, so I will put it here.

That’s happen when I want to compile my model using GUIStudioMDL. Never had that error before, so I’m confused.
I choosed gameinfo.txt which is placed in:

[…]\common\SourceSDK\bin\ep1\bin
studiomdl.exe also is there

After SteamPipe i really don’t know what to do to fix that …

@edit
Config doesn’t work. I remember that this isn’t necessary to set up properly.

I don’t think GUIStudioMDL really works any more, you’d be better off setting up a batch file and compiling through studiomdl.exe itself.

It does still work, but it’s honestly more of a hassle to get working than it should be.

I have this problem too, i only use Source SDK to set the path of VPROJECT, but if i use the .exe or .bat file for HLMV, i’ll still get that error, except some games like Synergy and Team Fortress 2 work (.bat works after editing it for each game), but Team Fortress 2 has an issue where it says it can’t find the folder you’re trying to enter, and that happens with both HLMVs