Unable to load Steam support library.

Hey guys I’m getting this error:

And I’m starting it up with a .bat file using this command:

What I’m trying to do is get a connection based off Internet not LAN so I can have a server that my friends and I can all join. And yes I have forwarded all the ports required for a dedicated server.

Please Help.

http://www.facepunch.com/showthread.php?t=960418

Found this on the 4th page of the thread Nisd posted above.

Worked for me :smiley:

I’m getting this as well.

Make sure your steam.inf inside orangebox/garrysmod/ is the following:


PatchVersion=1.0.1.0
ProductName=garrysmod
appID=4000


Now I get the “Your Client has a different version than the Server” Error when I try to join.

Do what the above guy said, worked for me.

Here’s what you need to fix your server, this is what Ive deployed to my hosting customers.

http://filesmelt.com/dl/GMOD.zip

Try

PatchVersion=1.0.0.76

You guys are amazing. Now I just have to figure out how to start up an RP server.

.76 gives the different version error and the 1.0 has the master server spamming the console with update and restart

So there has been an Update. What now? Updating with the HLDSTool does nothing. Because now I get the Version Mismatch again.

Posted this in the thread Nisd refered to above:

Apparently the steam.inf file should look like this:


PatchVersion=1.0.0.86
ProductName=garrysmod
appID=4000

1.0.1.0 has been working for me so idk.

I have the same thing now, although it’s a different cause, none of the suggestions above work for me.