Unable to Start Gmod server after Update

My Error log pls help


Console initialized.
 failed to dlopen /home/gmod5/orangebox/garrysmod/bin/server_srv.so error=/lib32/libm.so.6: version `GLIBC_2.15' not found (required by /home/gmod5/orangebox/garrysmod/bin/server_srv.so)
./srcds_run: line 372: 23051 Segmentation fault      (core dumped) $HL_CMD
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Fri Feb  8 00:27:02 MSK 2013: Server restart in 10 seconds

Garrysmod goes into lan mode on windows servers…

I have a linux server (=

I was going to make my own thread/post with this, but better we have it all in one spot in my opinion.

I updated my server for the latest patch and went to start it up. I recieved this error.

For reference I am running Debian 6 64bit.

Console initialized.
failed to dlopen /home/srcds/srcds_1/orangebox/garrysmod/bin/server_srv.so error=/lib32/libm.so.6: version `GLIBC_2.15’ not found (required by /home/srcds/srcds_1/orangebox/garrysmod/bin/server_srv.so)
./srcds_run: line 372: 24821 Segmentation fault

My startup command is
./srcds_run -console -game garrysmod +map freespace06_v2-1.bsp -maxplayers 16 +ip 216.244.65.83 -port 27015 -verify_all -autoupdate -debug

I also updated with
./steam -command update -game garrysmod -dir . -verify_all
It then downloads the “missing” files in bin, but does it everytime I update as if they are not being downloaded.

0:27 [208.64.200.9:27030] Reusing connection
0:27 [208.64.200.9:27030] Sending login message…
0:27 6.95% downloading ./orangebox/bin/datacache_srv.so
0:27 17.66% downloading ./orangebox/bin/dedicated_srv.so
0:27 56.23% downloading ./orangebox/bin/engine_srv.so
0:27 57.15% downloading ./orangebox/bin/libsteam_api.so
0:27 59.52% downloading ./orangebox/bin/libtier0_srv.so
0:27 62.79% downloading ./orangebox/bin/libvstdlib_srv.so
0:28 83.04% downloading ./orangebox/bin/materialsystem_srv.so
0:28 84.19% downloading ./orangebox/bin/scenefilecache_srv.so
0:28 86.10% downloading ./orangebox/bin/shaderapiempty_srv.so
0:28 88.75% downloading ./orangebox/bin/soundemittersystem_srv.so
0:28 100.00% downloading ./orangebox/bin/studiorender_srv.so
0:28 [208.64.200.9:27030] Disconnecting
HLDS installation up to date

So I am receiving the same error and you aren’t alone! I am guessing we just have to wait for an update =/.

http://www.facepunch.com/showthread.php?t=1245671

now it wokrs (= Close please

I believe I shall bump this.

I’ve had this issue the past month or so, made a post about it before the update hit but had no replies.

The issues has resumed for me on Debian 7, multiple servers with fresh installs.

On Debian Wheezy, follow these instructions to fix: http://stackoverflow.com/a/21254623
Works for me.

What I need to do for CENTOS?

Testing this now. Will let you guys know if it worked!

EDIT1: Confirmed working at one of my servers so far… running the same process on the other two.
EDIT2: Confirmed working for the second server… moving on to the last one.
EDIT3: Confirmed working for the third server as well. Thanks a lot!

I have no experience with CENTOS, sorry.

need helpafter i loaded up garry mod it wont let me my server im haveing nothing but probems with garry mod and no textures what can i do people this stuff i rill buging me where i dont wont to play thes games any more thanks again

Thanks!! Worked for me too!
My OS: Debian 7 x64bit minimal installation

Did you tried to reinstall gmod (+ a source game)?