Unknown command "sv_defaultgamemode" ....

i have looked on google to try and find out why and i cant so i am here now

server.cfg

sv_defaultgamemode “TEST”

test is a gamemode i am making i just called it TEST for now

Put +gamemode “test” in your start.bat.

there is no .bat as its a hosted server i have bought

at least i dont see one

Is there a place to put startup flags or parameters.

server.cfg is executed every time the server boots up or the map changes (changelevel or map command)
autoexec.cfg is executed the first time the server boots (For example: Exiting Server then it’s booting up, it will execute autoexec.cfg) Not executed when map changes.

could it be autoexec.cfg

No. What host are you using?

You can use autoexec.cfg to load a gamemode, although obviously it isn’t the ‘best’ way to do it. Just put



gamemode gamemodenamehere


in it and it’ll load.

creeperhost

[editline]26th May 2015[/editline]

still says sandbox

If they are using TCAdmin it is probably called Command-Line Parameters or something.

i believe they dont use TCAdmin but idk

Couldn’t change active gamemode - ‘TEST’ not found

i think am getting some where

Yes, now replace the “test” part with your actual gamemode.

yes but you see taht is my name i have for it right now but it seems even if i go back in my files and change it to order it still dosent work

my gamemode was called test
that didnt work

so i changed it to order
still dosent work

--------order.txt---------

“order”
{
“base” “base”
“title” “order”
“maps” “^OR_”
“menusystem” “1”
“settings”
{
// TODO: put some settings here
}
}

so any one have any ideas?

http://files.catbox.moe/ass.png

It’s whatever the folder’s name is. Not gamemodename.txt or its contents.

the folder is called order…

it was test but i changed it to see if that would work

and its a rented server

https://dl-web.dropbox.com/get/Public/ughh.png?_subject_uid=192258276&w=AAA2hh0o9aC2GSnMGiDd0c1jvyMPAp1OXP7bK8iw2yHJ4g