Unofficial Bug Report Thread

OK Guys, make stupid complaints on other threads, this is specifically to report bugs and give a full report on when and how they happened so try to follow my style here.

Date: 5:24AM - 16th of January, 2008 GMT

Computer Specs:
– Processor: Newcastle AMD Athlon 64 3800+
– Graphics Card(s) [at least the ones I tested it with]: ATI Radeon X600XT 256MB & nVidia GeForce 8600GT 256MB (both PCIe)
– RAM: 2GB DDR400

Bugs:
– Multiplayer not working: HELL YEAH (probably due to servers not having updated yet)
– Water missing textures: NO
– Water lagging the crap out of the computer: NO
– NPCs not disappearing after spawned: YES
– Problems with fire: NONE (that I noticed at least)
– Garry’s Mod crashing randomly: NO

Problems with Addons:
– LS2, RD2 and so on don’t work: YES (CDS works fine, as well as Wire)
– Vehicle packs not working: YES (none of them work)
– SmartSnap not working: NO (some people reported this but works fine, update it >_<)

Also, all prop packs I had installed work fine, those Include the Star Wars pack, PHX Stuff, Spacebuild build pack, basically everything popular and some unpopular stuff.
Stargate works fine, forgot to test Conna’s stuff and so on :\

Anyways, I had a lot of addons installed and none of them crashed gmod, even the ones that didn’t work, they just didn’t work, everything else works fine :slight_smile:

If your game crashes, GIVE GARRY CRASHLOGS :stuck_out_tongue:

No crashes but the AI is pretty buggy. I was on no target and checked out the AI, and it was horrible: My Ant guard was ramming into airs as if hit was actually hitting something and lost interest in rebels after 5 second. Hunters for some reason, don’t spread out and do whatever they did in Garry Mod Beta, they just group together into one tight pack and attack/hump each other with their spears. I tried to just put one and what it did was hilarious: It kept shooting upward in the sky with their gun thingy for no reason…

Yes that is basically the same problems I have. I think the other problems for the other people are there computers, and they think its gmod :stuck_out_tongue:

The only problem with my NPCs combine solders won’t attack you unless they have a pistol or SMG they do the elbow attack when your close.

and its funny when they shoot you with the pistol, they stand completely striate up with there arms out to there sides and they fire like that. It funny.

Damn it mate, you beat me to it.

Add this one, multiplayer screenshots come out as images of pure black.

Only thing that I noticed that was wrong with fire is that it doesn’t give off light, like it should.

Hosting a listen server will make the host lag in an odd way…

If you knock a turret (combine) over in ctf 2fort you crash. Oh and I can’t pick up tf2 turrets.

bump Well, seems most problems are because of peoples computers, mine only has those general problems that everyone got (multiplayer, ragdolls not disappearing, addon incompatibility), hopefully this will keep the MingeBags away :smiley:

Got one more. Gibs are not being precached.

I just went to try it out again today and I can’t even play, first GMOD crashed when loading a Custom map with an “Engine Hunk Error”, then I tried gm_construct and got an OS Paged Pool Memory error >_<

Edit:

I just did a complete check on all the addons I have installed, as well as default gmod stuff, here’s what I found out:

  • GMOD Crashes when creating a lot of icons for prop packs (happened before this update as well)
  • NPCs don’t disappear after killed (except for the Zombie Barnacle)
  • Combine Prison Guard spawns YELLOW
  • Combine Elite spawns PINK
  • Water doesn’t lag when looking at it.
  • Igniter works fine, the timer for it works fine, only problem is that fire keeps burning even when underwater.

Prop packs that work:

  • Builders Pack
  • PHX (all)
  • PC-Tuning
  • Kathars Models
  • Spacebuild Model Pack
  • Building Blocks by Om3ga
  • Resident Evil 4 Weapons + Models
  • DOA Models
  • Carmod props
  • GMOW v3 Props
  • Rails

Addons that work:

  • Smart Constraint
  • Smart Weld
  • Smart Remover
  • Smart Snap
  • Advanced Duplicator
  • Wire Mod
  • Fin Tool
  • Bridge Tool
  • Wing Tool (kinda)
  • Ulib (kinda)
  • GCombat
  • CDS
  • Weight Tool
  • Stacker
  • No Collide Multi
  • Prop Resizer
  • Stargate

Addons that don’t work or mostly don’t work:

  • ULX
  • Shield Tool
  • Smart Rotator
  • Shanjaqs Gravity Plating
  • MadJawas Laser and Launcher
  • Connas Tools
  • VMF Suite
  • Pyroteknix
  • Time Control
  • LS, RD, SB, Oilmod, LS2, RD2, SB2, Petrol Mod, and all that stuff.
  • All Vehicle Packs

Hope this info is helpful to someone :stuck_out_tongue:

Yeah I can’t pick up TF2 dispensers I haven’t tested turrets yet.

Oh, and I forgot to post this last night…

Both “Sentry2” do not spawn right. They flip over and trippy shit like that.

The big room you go into to press the button to open the fire thing in Portal is on a lean.

When one of the tables from the Portal pack is spawned, then a Stool (A real stool :downs:), the stool can be spawned in the ground.

Edit:

Another one I have here, the “bts_shelf_static” in Portal pack is all pink with black squares.

Get SmartSnap 0.9.4 and it should work for you, if not, try to see if you get any errors and report them in the SmartSnap thread.
http://forums.facepunchstudios.com/showthread.php?t=322155

When downloading content, only lua files are chaging.
For example: There are in total 45 files to download. 20 of them are lua files.
When 15 of them are downloaded, it shows 5 lua files.
It doesn’t change for other files. Even if all misc files are downloaded, it still shows 25 other files.

My biggest non-addon problem is that my thrusters can’t produce over 10000 thrust. I’ve tried a fresh install, but they’re still limited. This makes it very hard to work with anything larger than a filing cabinet.

Yeah the truster problem is bugging me too.

my hunter on gmod is an hl:s helicopter

Biggest bug for me is being unable to load a save game you have made with the new version of GMOD without it not showing up saved objects then crashing (happens with and without addons and i don’t mean loading a saved game from a previous version of GMOD). I have stopped playing GMOD since this bug came into effect. Heres the topic with more details http://forums.facepunchstudios.com/showthread.php?t=488502

I found a bug for almost everyone, you cannot weld stuff to the ragdolls with the Weld Tool since last update, I want you Garry to hurry up and fix it. Pls for our sake, it’s frustrating our posing!

BanjaminTennison: Bugs are meant to be post on the official bugtracker - http://bugs.garrysmod.com/