Unplayable FPS with terrain details >20 / shader level >200

So I’ve been playing the new version of Rust like a month or so ago and it was mostly running fine - I couldn’t max it but I didn’t expect it either, still, it looked nice enough and ran at a good frame rate.
Today I’ve decided to try it again - the main difference being that I’ve installed Windows 10. And now I’m having the problem mentioned in the thread title - whenever I try to go with terrain details over 20 or shader level over 200 (either one of those is fine but both together makes it impossible to play) my FPS drop from 60 to 10-20. This definitely didn’t happen before and I don’t know if this is Windows 10 related or not as I do have the latest GPU drivers available for my card.

I’m using a i5-2500k at 4.3GHz and a GTX770.
Any help would be much appreciated.

Man, I should just copy paste this fix for everyone having an issue with Rust.

First, open up your Nvidia Control Panel and make sure Rust.exe uses your GTX 770.
Secondly, download Nvidia Inspector from here. Run it as Admin, and press the icon that looks like a screwdriver and wrench.
This is the profile window. You can select games by name, which come with their appropriate profiles provided by Nvidia’s drivers, and then choose specific settings for each game. For Rust, I would suggest doing the following:
Under “Sync & Refresh”

  1. Frame Rate Limiter = 120 FPS. You don’t need a higher framerate than that.
  2. Maximum Pre-rendered Frames = 1

Under “Anti-Aliasing”

  1. Behavior Flags = None
  2. Anti-Aliasing Mode = Override Application Settings
  3. Toggle FXAA On or Off = On

Under “Texture Filtering”

  1. Anisotropic Filtering Mode = User Defined/Off
  2. Anisotropic Filtering Setting = whatever setting you currently use for Rust.
  3. Prevent Anisotropic Filtering = Off
  4. Texture Filtering - Anisotropic Filter Optimization = On
  5. Texture Filtering - Anisotropic Sample Optimization = On
  6. Texture Filtering - Quality = Anything but “High Quality”
  7. Texture Filtering - Trilinear Optimization = On

Under “Common”

  1. Multi-Display/mixed-GPU Acceleration = Single Display Performance Mode
  2. Power Management Mode = Prefer Maximum Performance
  3. Threaded Optimization = On

All these settings should offer you a much better and slightly less texture-buggy experience. Enjoy, mate.