"Unsupported 32-bit wave file" SWEP sound problem.

Hello everybody, I really hope I’m posting in the right forum here. If not, my apologies.

I’ve tried searching for this problem on google and on facepunch, with little to no results. I’m basically trying to edit a SWEP just to change the sounds. At first I was having problems with Garry’s Mod finding the files at all, but I think I got that figured out. What happens now, though, is boggling my mind. I keep getting an error that says something along the lines of “Unsupported 32-bit wave file”, followed by the typical “cannot play ‘weapons/example.wav’, probably not found on disk/repository”. If Garry’s Mod can detect that it’s a 32-bit wave file, then I’d reckon it knows where the file is. So I take the files and open them up in Edison, make sure they’re 16-bit int, 44k stereo .wav files, then replace the old files and update the workshop file. The error persists. I’ve tried rebuilding the audio cache in-game and that did absolutely nothing.

Any help/advice would be greatly appreciated. Thanks.