Unusual GPU interaction.

Hello! I own Rust for about a month, and since the beginning i had FPS issues.
I currently use a Mid-Range Laptop, which can run most games fine, not at the highest settings, using a Nvidia 2gb Geforce 630m.
I got average ~20fps with graphics preset Fastest and “grass.on false” command, which i find weird since i don’t think this game is that much GPU intensive, but i didn’t complain for the reason the game is still in Alpha.
But, for testing reasons, i decided to change the GPU Rust was using(most laptops come with an integrated card, and a dedicated) to Intel HD 4000 graphics, which is normally way slower than the 630m, and obtained a weird result, with the same configuration before, i was able to get ~30fps average.
I just find it weird that my weaker card can run the game better than my dedicated one.

Here are my specs:
Intel Core i7-3630QM 2.40Ghz
8gb RAM
Nvidia Geforce 630m
1Tb HD 5400RPM
Windows 8 64bits.

If someone can tell me why is this happening, it would be appreciated! Thanks in advance.

windows 8? people actually installed that?


(User was banned for this post ("help or don't post" - postal))

try using a different graphics driver for your Nvidia card…try updating it, if that doesn’t work try rolling back to an older version

also see if there are beta drivers for your particular card try those aswell and test to see if there is a difference

try running Msi Kombuster to load test your gpu

I have the exact same specs on my laptop except i have windows 7. I get about 25 average with 630M, i will test with HD4000 and see the result. I will update it here then

Sounds like mine - I think it’s just the server getting used to the lag from so many players man. In response to the guy below - some of us didn’t BUY Win8, we had Win8 thrust upon us - personally I’d take it considering I have those same specs (well, 2.2GHz) and paid $680 for it.

Edit: Not that he’ll ever see my snarky reply…

Have you tried lowering the render quality? That helped me. Stupid question #2: are you remembering to set grass.on and grass.displacement to false in the console? It should boost your FPS to a point that unless your server has insane hacking you should be able to game pretty consistently.

i have the EXACT same problem with my notebook as i posted on the other topic. integrated video card gets better performance than my gt750m. So far i noticed the problem is more related to MOBILE vcards only.

Your computer wouldn’t be an Asus K56CM would it? Yeah it should run it but not with good settings…also keep it cool with a cooling pad!

I tried with 3 different drivers already(332.21, 326.80 and 331 beta) and so far the result has been the same.
Just tested the GPU Load with Msi Kombuster, it looks fine as a solid 95%+ usage.

[editline]17th January 2014[/editline]

Yes, i did reduce the rendering quality to the lowest possible. Sadly the FPS didn’t improve that much(almost nothing)
Yeah i have both commands set to false (“grass.on false” and “grass.displacement false”), the fps improved a little bit, but not by much.

[editline]17th January 2014[/editline]

No, it’s a Samsung series 5 NP505C(something like that). Now that you mentioned it, i will see if the problem is not GPU Throttling. Thanks for the tip! :slight_smile:

gfx.ssaa false

Youre welcome.

I actually run another test on MSI Kombustor, it seems that my GPU isn’t giving full performance for some reason(75% only)
I tried checking if the GPU was throttling, turns out it was a bit(the clock reduces from 700mhz to 550) so i used Throttle Stop to prevent this, which improved the GPU load, but had no FPS improvement at all. :confused:

[editline]17th January 2014[/editline]

That helped a bit, thanks!

If youre throtteling on kombustor, it sort of has to be a heat problem. That shouldnt be solved by using software to lock your clocks dude. Also, the keppler boost 1.0 doesnt downclock based on heat in the same way boost 2.0 (700-series) does, so your freq should be locked to your voltage not your temps.

Id start checking my temps using hwmonitor or somesuch. During benchmarks you should be bottoming out. However a lot of laptops downclock when not plugged into the wall, might wanna try that.

Also, get the newest afterburner and nvidia drivers.