"Up Vertex buffer size"?

My map is full of brushes, and has no optimization YET, but when I ran it and played, I noclipped and flew into the sky… It promptly crashed and told me to tell a programmer to “Up Vertex buffer size”… So how do I do that?

I suggest optimizing, I’m not sure exactly what that error is, but I have a feeling that offsetting some of your more complicated brushwork to func_details will lower the world vertex count and it might help…

func_detail isn’t going to lower the amount of verticies in a map.

VERTEX_BUFFER_OVERFLOW is caused by two things:

  1. poorly made map.
  2. using func_precipitation in large areas with ridiculous density settings.

It’s more likely that hint and areaportals are going to save you here, depending on what the map looks like of course. Basically the error is saying there are too many vertices trying to be rendered at once.

It’s fairly open, rendering that nearly impossible, though I have used them in one spot that was closed off enough…

It’s not a vertex overflow though…

Infact The only reason I ask is because I’ve never seen the error before, and I was wondering what the hell it meant.

Yeah, I am hoping that’s the case.