Update not actually updating.

I’ve tried updating my DarkRP server & a few others, still getting the “The server you are trying to connect to is running
an older version of the game.” error.

I’ve tried app_update 4020 and app_update 4020 validate, still no luck.

Are you using a custom install folder for the server?

install_dir_override or whatever the command called?

Are you entering the commands directly into the SteamCMD window or are you using a .bat file to run SteamCMD and update the server?

I don’t know what you mean by custom install folder, it’s in C:/Servers/DrugRP/
I’m entering the commands directly into SteamCMD like so:



login anonymous
force_install_dir C:/Servers/DrugRP
app_update 4020 validate


It worked fine for my OldschoolRP (DarkRP) and Deathrun server, but not the other 4 servers.

Well, force_install_dir is what I am talking about

It is known to cause problems with not updating the server properly.

Unknown command “install_dir_override”

What should I do?

No, by “install_dir_override” I meant “force_install_dir”, I just couldn’t remember the command.

As I said, the command is known to cause problems with not updating the server properly.

Okay so I should just do nothing and let my servers be broken & unplayable?
It worked for 2 of my servers, but not the other 4.
This makes no sense, I don’t see how this would suddenly happen from a simple update.

I never said do nothing.

I’d say it’s a bug with SteamCMD, what you should do is either copy all base files from working servers or reinstall the servers.

You could also just make a new server and copy all files from it to your servers. Just make sure not to override your configs and custom files.

Every single time there’s a Garry’s Mod update, something breaks, and every single time i’m told to “reinstall my server”

Sorry, but I’m getting really sick of this shit. Every update comes with more broken stuff that just causes issues & pisses off server owners.

I don’t have time to sit here and re-do ALL of my 7 servers. How about fixing the game or not updating it at all, that’d be great.

[editline]11th August 2015[/editline]

It’s saying something about a config being “potentially out of sync” when I update my main DarkRP server.

Don’t blame Garry’s Mod for problems of Valve software. We didn’t make SteamCMD and any problems that come because of it are out of our control.

The best I can do is suggest a workaround.