Update or restarting server = map reset

Hey guys.

Im having the problem that the map becomes resetted after restarting or updating the server.
I have lost 80% of the community yet.

I am using the experimental server version.

How to fix that?

My start.bat:


@echo off
RustDedicated.exe -batchmode -autoupdate +server.hostname "tool experience | OXIDE COMING SOON" +server.port 28015 +server.identity "tooldev" +server.seed 6738 +rcon.password "**" +rcon.port "0"

Thanks for your attention.

-load near the end of the bat… there is many posts on this now :stuck_out_tongue:

Ow Ive tried it like that the last time. But my maps are still lost. :frowning:

But thank you.

From time to time after a build update, saves get incompatible.

Ok, that s*cks :frowning:

and if you started the map without the -load the save file was overwritten once the server saved. you will see an error when the save file is no longer compatible.

Sorry, but -load doesnt fix anything. Next map gone -.-


@echo off
RustDedicated.exe -batchmode -autoupdate +server.hostname "tool experience" +server.port 28015 +server.identity "tooldev" +server.seed 6738 +rcon.password "****" +rcon.port 28016 -load

Multiplay server by any chance?

Kept having the same problem with them myself, every time we did a server restart, it reset everything.

toolchain

Are you setting the working directory correctly? - i had this before when automating my server restart on crashes - then to find my server was saving files to my desktop

Im not sure if I understand you. :smiley:
Whats a “working directory”?