"Updating" Server list wont show up?

ANyone else not able to join a server since this the update this morning? Now mine is stuck on “updating”. So I cant join my last server or even see ANY servers.

Anyone?

I’m having the same issue too. You’re not alone.

Update:

When I reboot, steam keeps telling me there is an update for RUST. But it installs it and still hangs at the server browser screen with “updating” stuck at the bottom.

[editline]24th January 2014[/editline]

FINALLY! Ok guys, I rebooted a few times. Steam ran updates a couple times and now Im in!

Check to make sure you’re not in DEV BUILD mode. To do this go to your game library in steam, right click on Rust on the left side of your screen, and select properties, once there go to the Betas tab and select None under the Select Beta To Opt Into.

I’m having this issue as well. I’ve validated my files, I’ve reinstalled, I’ve made sure I wasn’t in Dev build. I’ve restarted Steam multiple times. NOTHING. No servers are showing up, it just sits at updating. I tried using the net.connect to connect to servers and still no luck! I need some assistance!