Uploading an addon to the workshop

I am trying to upload my very first addon to the workshop. I have scavenged the internet for some sort of clear tutorial on how to do so. I have made an addon.json file in my addon folder and I have my code under lua/weapons/schitthrower (Don’t ask). Is there anything else I need besides that? At this point I cannot figure out how to convert the addon folder to a gma file. I have seen this: http://forum.facepunch.com/showthread.php?t=1242185 When it says

I have no idea where I am suppose to input that command line in order to create the gmad file.

Perhaps my Command Prompt? If so how? I have also tried going straight to the gmad.exe file in my gmod tools folder and when I click on it, it opens for a split second then closes again.

You need to create a batch file and put that code with the proper variables in it, and then run the batch file.

Copy gmad.exe to a folder on your desktop, create the batch file in there, and run the batch file.

I did exactly that and a small screen open up and then closes immediately. This is what I have in a start.bat file


gmad.exe create -folder "C:\Users\MyLastName\Desktop\shitthrower" -out "C:\Users\MyLastName\Desktop"

And it is in the same file as gmad.exe

put PAUSE after that, and what does it say. Also, -out needs to be the name of the file with a .gma ending.

I tried putting pause and PAUSE at the end of the command line. Neither worked for me.

EDIT: Still closes upon opening. But I do see a glimpse of an error in the program but it fades out too quick to read it.

Are you sure you’re saving it as a .bat file.
Are you running the .bat file and not gmad.exe.

I still think it was silly to make uploading things to the workshop require the use of batch files and stuff. I guess it keeps a little bit of quality control.

What did it say though? Make sure you put pause on a new line in all lowercase.

It says a lot. And I can’t copy and paste it. Might take me a bit


C:\Users\MyLastName\Desktop\gmad extractor>gmad.exe create -folder "C:\Users\MyLastName\Desktop\shitthrower" -out "C:\Users\MyLastName\Desktop"
Garry's Addon Creator 1.0
Looking in folder "C:/Users/MyLastName/Desktop/shitthrower/"
        lua/weapons/schitthrower/shared.lua
File index: lua/weapons/schitthrower/shared.lua [CRC:1753061358] [Size:3.0 KB]
Adding lua/weapons/schitthrower/shared.lua
Successfully saved to "C:\Users\MyLastName\Desktop.gma" [3.2 KB]

C:\Users\MyLastName\Desktop\gmad extractor>pause
Press any key to continue . . .

[editline]21st August 2014[/editline]

I figured out how to. But, thx.

Okay. So it worked. Now, you have to use GMPublish to upload it.

Thx for the help :wink:

[editline]21st August 2014[/editline]

A new problem arises. When I setup the GMPublish command line I get this error:


C:\Users\MyLastName\Desktop\GMPUblish>gmpublish create -addon "C:\Users\MyLastName\D
esktop\shitthrower.gma" -icon "C:\Users\MyLastName\Desktop\shitthrower\poop.jpeg"

Garry's Workshop Publisher 1.0
[Compiled Jun  8 2014 - 17:16:08]
Error:

Couldn't initialize Steam! (Is it running?)


C:\Users\MyLastName\Desktop\GMPUblish>pause
Press any key to continue . . .

I rebooted the start.bat file with steam opened as well. At first it said steam_api.ddl was not on my computer so I downloaded a “fix.” Probably not the best idea but after that I am getting this error. Any ideas?

[editline]21st August 2014[/editline]

I’ll try to verify integrity of game cache if something is broken with my files. IDK What to do otherwise. Perhaps re-install Gmod.

Why dont people use Workshopper? Its old but insanely easy to use because it has an interface. This seems like more work than its worth

Because it’s not hard to write a GMPublish script, and most people don’t have Workshopper since it’s not shipped with GMod anymore.