[Urgent] DarkRP toolgun help

I’ve been trying to get my DarkRP server up for two whole days now, and it’s really pissing me off. 4 server reinstalls and many hours later I’m still at square one. No matter what version of DarkRP I install, whether I get it from garrysmod.org or SVN, no matter what admin mods I do or don’t use, and no matter what settings I change on the server or DarkRP the toolgun still doesn’t work.

It doesn’t do anything. You can still hold and shoot it, but it doesn’t do anything. It works fine on any other gamemode so can somebody PLEASE help me?

rp_toolgun 1? is that the issue?

I’ve tried toggling rp_toolgun many times, no luck at all.

so are you just missing the file then? i know ive had a problem like this before. i wouldnt spawn with a grav gun and i coulnt get one. possibly your garrysmod… could be installed incorrectly

My garrysmod is installed correctly, everybody who joins the server has the problem. Also I can’t imagine the problem is a missing file because of the amount of different places I’ve downloaded and tried darkRP from.

try to install a sandbox gamemode and see if it works. if it does then somethings really fucked up. or try singleplayer and see if you have a toolgun because if u do its just ur server. if its just ur server id suggest sending a support ticket.

Just tried it on single player and it’s working fine.

You need for DarkRP

What?

The ToolGun its for DarkRP ??

Now that’s describing a problem properly. Do it this way next time you send me an e-mail. This information is vital. By this I can tell there’s a serverside CanTool hook that returns false.

Could you please enter this in the SERVER console:


lua_run PrintTable(hook.GetTable().CanTool)

and give me the output? (It should print random text of between 3 and 20 lines, can be more)

Just a long-shot here, a few basic ideas.

[ul]
[li]Does the server let you use the toolgun in any other gamemodes?[/li][li]Have you installed any addons/admin plugins?[/li][/ul]

Those are pretty good questions. Perhaps my way of solving it is too technical. Try these ideas first.

I have the same problem I tested everything possible it all only has to do with the DarkRP latest svn. Same exact problem nothing different.

Additionally FPtje

EntityCanTool = function:019D24C0
FAdmin_Log = function 019CE098
FAdmin_jailed = function: 019D0D08
FPP.Protect.CanTool = function: 01E09000