[URGENT] fetching workshop addons -no authkey

Hello everyone,
I am running a sandbox server using SRCDS, after today’s update, none of my workshop addons from my workshop.VDF file show up,
and I get ‘fetching workshop addons -no authkey’ in my server console window.
I have windows server 2003, and I have about 30-45 people on my server daily! I need help!
Any insight whatsoever would be appriciated!

Thank you.


(User was banned for this post ("You don't need to spam support with requests to read your thread" - garry))

–DELETE–

Have you checked the changelog?

"Dedicated Servers use Workshop Collections

Throw away your workshop.vdf file - because you don’t need it. The workshop for dedicated server system now works the same way as CS:GO."

https://developer.valvesoftware.com/wiki/CSGO_Workshop_For_Server_Operators

I Have this issue also and I tried this http://wiki.garrysmod.com/page/Workshop_for_Dedicated_Servers . I am running Linux. When I tried this it still would not load my legacy addons or my workshop addons. I thought I give this to you to at least try and help you out instead of leaving you with no direction.

----edit----
Never mind got it working. The way i linked works. Now to see if I can get legacy addons working or if he is only doing collections now.

Legacy addons don’t mount for me either on Linux server. A friend of mine hosting Windows is not having this problem, though. Maybe a Linux specific issue?

Legacy addons aren’t loading for me either since the recent update.

Edit: Linux

Now I’m getting ‘That item does not exist. It may have been removed by the author.’ when trying to make an addons list!
What is Valve doing to it’s workshop!?
HELP!

[editline]26th February 2013[/editline]

I’m running Windows server 2003

[editline]26th February 2013[/editline]

Ok update:
Thanks to ‘bran92don’ I fount the site that allows me to make the ‘Workshop collection’ crap that I need to run my server, and I can’t create a collection because I get this error when I click create:

That item does not exist. It may have been removed by the author.

Once I get this obnoxious system working,how will we get legacy addons to work!?

Do not put the Workshop collection option on your server because is crashing my if i remove it run normally but not give me the addons…

Is your collection published? Does it contain addons that don’t exist on workshop anymore?

EDIT: Again
They fixed the error with the Removed by author.

Let’s find out about these legacy addons… shall we?

Well form what I read he has gone back tot he old way of doing addons to help support gmod12 addons. I am guessing we might need to change the addon.txt or something. The thing is optidash says his friend who is on windows has no problems, so that might not even be the issue.

Where do I put up my server addon pack line of code?
In my SRCDS startup line?

[editline]26th February 2013[/editline]

Oh god… the errors!


Missing shutdown function for Sys_InitAuthentication() : Sys_ShutdownAuthentication()Missing shutdown function for S_Init() : S_Shutdown()Missing shutdown function for Decal_Init() : Decal_Shutdown()Missing shutdown function for InitStudioRender() : ShutdownStudioRender()Missing shutdown function for StaticPropMgr()->Init() : StaticPropMgr()->Shutdown()Missing shutdown function for modelloader->Init() : modelloader->Shutdown()Missing shutdown function for InitMaterialSystem() : ShutdownMaterialSystem()Missing shutdown function for HLTV_Init() : HLTV_Shutdown()Missing shutdown function for g_Log.Init() : g_Log.Shutdown()Missing shutdown function for master->Init() : master->Shutdown()Missing shutdown function for sv.Init( bDedicated ) : sv.Shutdown()Missing shutdown function for g_GameEventManager.Init() : g_GameEventManager.Shutdown()Missing shutdown function for NET_Init( bDedicated ) : NET_Shutdown()Missing shutdown function for Key_Init() : Key_Shutdown()Missing shutdown function for Filter_Init() : Filter_Shutdown()Missing shutdown function for saverestore->Init() : saverestore->Shutdown()Missing shutdown function for COM_Init() : COM_Shutdown()Missing shutdown function for V_Init() : V_Shutdown()Missing shutdown function for cv->Init() : cv->Shutdown()Missing shutdown function for Cmd_Init() : Cmd_Shutdown()Missing shutdown function for Cbuf_Init() : Cbuf_Shutdown()Missing shutdown function for Con_Init() : Con_Shutdown()Missing shutdown function for Memory_Init() : Memory_Shutdown()Missing shutdown function for Host_Init( s_bIsDedicated ) : Host_Shutdown()Missing shutdown function for Sys_InitMemory() : Sys_ShutdownMemory()Missing shutdown function for Sys_Init() : Sys_Shutdown()Missing shutdown function for COM_InitFilesystem( info.m_pInitialMod ) : COM_ShutdownFileSystem()

Help please! Am I the only one!?

yea I know I get those too but my server stills runs. I have been unsuccessful in fixing all of them. I could not get my server running for a while and when i finally go it up I broke it again. I eventually just set it aside for now and just got it to were my server would actually start up.

Facepunch is blowing up with these problems, I guess i’m not playing on my server today. :tinfoil:

[editline]26th February 2013[/editline]

Edit: Some people are saying that Workshop is under maintenance. Could that be causing my ‘Missing shutdown function…’ errors?

I just noticed even though my linux srcds is saying it’s mounting the addons from the collection, they don’t actually seem to be working.

Apart from that I still haven’t gotten legacy addons to work.

Basically it’s not running any addons at all.

Ugh I’m getting the same problem. Very, very, annoying. I hope all of this is explained in the near future. I keep crashing on Getting Collection Details as well… sigh :suicide:

Couldn’t have said it better myself.

[editline]26th February 2013[/editline]

Agreed completely.

**Fix by Garry:

http://forum.facepunch.com/showthread.php?t=1249837&p=39726545&viewfull=1#post39726545**

Just tested and works perfectly for me.

Still getting tons of those GetCollectionDetails errors

Everyone:

I installed the so called ‘fix’ garry posted, but I am still getting:
“Missing shutdown function for…” Errors!

Did anyone have this?
How did you fix it?
PLEASE HELP!

**EDIT:

I found out that the Missing shutdown functions were caused by my workshop collection startup command.
**I now don’t have any of my workshop addons, but my legacy addons are loading.