Urgent - Players can spawn cars and Owners cant?

Okay, so sorry in advance for possibly posting in the wrong section, the help and support never gave me as much help as this section did, and this is an urgent issue to me that I cannot find a fix to.

So I have noticed the rank “user” can spawn in any car (tdm cars and what not) under the q menu in the vehicles tab). They can spawn endless amount of cars. The ranks that can spawn cars are: user, Regular, VIP, SuperVIP, Mod, ModV, ModSV and Admin.
The ranks that cannot spawn cars SuperAdmin, HeadAdmin, Owner.

The default ranks in ulx that can spawn cars are operator and user and admin, and superadmin cannot. I made the Owner, SuperAdmin and HeadAdmin ranks go off the superadmin rank, while the rest of the ranks went off admin, operator or user.

Can someone please help and figure out why in gods name the upper staff CANNOT spawn in cars while everyone else lower can? this is a really stupid issue that I cannot find a fix for. I will explain further if needed.

If you are running fadmin, it would be underneath those settings in the options tab. If you are just running a stock server, I could help you out making it so the right users can spawn cars with lua.

What setting would it be? where would I be looking and what setting exactly

What kind of server are you running? A darkrp server? If not, you most likely don’t have fadmin. It would be in options in the q menu under fadmin.

I am running darkrp.

[editline]3rd March 2016[/editline]

There’s no faadmin in option in q menu

In that case, go to the darkrp settings in darkrpmodication folder. Change the following line in the file:



-- adminvehicles - Whether or not vehicles should be admin only. 0 = everyone, 1 = admin or higher, 2 = superadmin or higher, 3 = rcon only
GM.Config.adminvehicles                 = 2


I am having the exact same issue. I have Fadmin installed and running. i checked the permissions in Fadmin and there is nothing in there. The immunities are their defaults. The ULX ranks are all but admin and superadmin can spawn vehicles. The serttings are sert to GM.Config.adminvehicles = 3. The ULX setting are set for 0 for vehicles spawn. I tried changeing from workshop ulx to github and no fix. I changed immunites in ULX and permissions and inheritence in ULX as well. Nothing seems to work. I feel like it’s a DarkRP bug if anything. I jsut really want this fixed.

Well, if all fails, lua. Put this in a script in autorun under server.



local allowed = { -- Allowed Ranks
	"superadmin",
	"admin",
}
hook.Add("PlayerSpawnVehicle", "usrChk", function(ply, model, name, tbl)
	for _, rnk in pairs(allowed) do
		if ply:IsUserGroup(rnk) then return true end
	end
	return false end
end)


Untested but should work. Make sure to set it so anyone can spawn vehicles in settings for this.

Still doesn’t work. Changed the settings too, but nothing.

Going to try using URS addon from workshop to restrict the vehicles, I’ll report my findings

Don’t. Remove FAdmin in darkrpmod/disabled defaults.

Download ULX or any other admin mod… FAdmin breaks stuff. Sorry Falco.

So I tried using URS. Did not work. Removed FAadmin, that was the issue, but now the ranks are pretty broken. Head Admins and below cant pick anyone up, only Owners can? How would I fix the chain system in ulx.

the ranks I have are: user, Regular, VIP, SuperVIP, Mod, ModV, ModSV, Admin, SuperAdmin, HeadAdmin, Owner.

I want to make it so Owners can pick up Head Admins but Head Admins cant pick up owners, then Head Admins can pick up Super Admins but Super Admins cant pick up anyone above them. You get the picture, a chain. user, Regular, VIP, SuperVIP shouldnt be able to pick up anyone and Mod, ModV and ModSV should all pretty much be the same, they can pick up anyone lower than themselves but cant pick up anyone higher than themselves. Mods should all be put into 1 group where they can all pick eachother up.

So basically, I have NO idea how to do this with ulx alone, I did it with FAadmin and removing faadmin broke it. Anyone know how to set this up?

Remake the ranks and in the cantarget selection just put:
Owner “*” So he can target anyone
Head Admin “!%owner”
Superadmin “!%headadmin”
and so on.

Okay so the problem fixed when I took this:

– adminvehicles - Whether or not vehicles should be admin only. 0 = everyone, 1 = admin or higher, 2 = superadmin or higher, 3 = rcon only
GM.Config.adminvehicles

and set it so 2, which is superadmin and above. I have no idea how that fixed the issue, seeing users would need to have the rcon password (it was on 3 before)