Users.txt dont work please help :(

Hi, im playing with my friends on my local client server, but im not admin. I know how to use users.txt cuz in the old gmod were i admin on my server.
Here is my users.txt… its located in C:\Program Files (x86)\Steam\steamapps\USERNAME\garrysmod\garrysmod\settings
(With other words, i just want to use clean up everything, admin, but it dont work. Not even in singleplayer :frowning: )


"Users"
{
	//
	// This is your users file
	//
	// You can use this file to add people as admins on your server
	// Add them to the relevant section
	//
	// If you're a Lua coder you can add your own sections and use them
	// in your script by doing pl:IsUserGroup( "admin" ) etc
	//
 
	"superadmin"
	{
		"andreaswurtz"			"STEAM_0:0:37689266"
	}
 
	"admin"
	{
		"UrinTrolden"			"STEAM_0:0:37689266"
	}
 
}

So what’s exactly the problem, who doesn’t have admin. Also, you DO realize that the two steamIDs are the same, for different names and in different categories right? That’s probably your problem, granted whoever “STEAM_0:0:37689266” is should have admin

The steam id is mine, and i changed he users.txt to look like this. But it still dont work


"Users"
{
	//
	// This is your users file
	//
	// You can use this file to add people as admins on your server
	// Add them to the relevant section
	//
	// If you're a Lua coder you can add your own sections and use them
	// in your script by doing pl:IsUserGroup( "admin" ) etc
	//
 
	"superadmin"
	{
		"andreaswurtz"			"STEAM_0:0:37689266"
	}
 	
}

[editline]6th December 2012[/editline]

well i think i am admin, but i cant use cleanup everhing (admin) and i cant use admin weapons or admin stuff like: PlayX Player, Airvehicles (with weapons)

Do you use some form of other admin mod?

nope, i used to use assmod but that made my friend’s (piece of shit) computer lag :confused:

I did some more looking around on other forums and apparently other people are having similar issues not getting users.txt to work, they all just used a third party admin mod instead. There’s nothing wrong with your txt file itself, and I haven’t really tried tinkering with mine. For the meantime I would just suggest using assmod again, If your friend’s computer can’t run a simple lua script, it may be time to consider an upgrade…

Similar Issue Here

That’s a dumb issue, he had “//” infront of his code thus canceling it out…

Thx for the help guys :3 But nothing of what u said worked :confused: So i uninstalled gmod and then it worked
CASE CLOSED :smiley: :smiley: